Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1054157 - MANAGED_BY should only contain URL, if server and port are set
Summary: MANAGED_BY should only contain URL, if server and port are set
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-vdsm
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Douglas Schilling Landgraf
QA Contact: Tareq Alayan
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-16 11:12 UTC by Fabian Deutsch
Modified: 2016-02-10 19:25 UTC (History)
7 users (show)

Fixed In Version: ovirt-node-plugin-vdsm-0.1.1-14.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, if the node was not registered with a Manager, the Red Hat Enterprise Virtualization Hypervisor status page displayed a 'http://None:None' URL in the "Managed by" column. Now, the "Managed by" field is only populated with a URL when a server and port can be detected.
Clone Of:
Environment:
Last Closed: 2014-06-09 14:26:16 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0673 normal SHIPPED_LIVE ovirt-node-plugin-vdsm bug fix and enhancement update 2014-06-09 18:24:50 UTC
oVirt gerrit 24421 None None None Never

Description Fabian Deutsch 2014-01-16 11:12:44 UTC
Description of problem:
Currently the MANAGED_BY text contains the URL even when no server an dport are set, e.g:
Managed by: RHEV-M http://None:None

The url should only be shown when server and/or port are set

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Upgrade from 6.4 to 6.5
2. Focus on status page
3.

Actual results:
URL with hhttp://None:None is shwon

Expected results:
URL should not be shown in Managed By text

Additional info:
When migrating from 6.4 to 6.5 we don't have the RHEV-M address/port, so we shouldn't display the URL.

Comment 2 Jiri Belka 2014-03-18 16:43:40 UTC
Please provide steps for verification, thank you.

Comment 3 Douglas Schilling Landgraf 2014-03-18 21:44:22 UTC
(In reply to Jiri Belka from comment #2)
> Please provide steps for verification, thank you.

As soon you install rhev-h, on status page you won't see "Manage by: None://None", it will only appear 'Status, Networking, Logs, etc' fields. The "Manage by" will appear as soon you register the node into RHEV-M.

So the test would be:
=========================
1- Install RHEV-H
2- Go to status page, should not appear "Manage by: None://None"
3- Register the RHEV-H to any RHEV-M
4- Back to status page and you will see "Manage by" with host and port.

Comment 4 Tareq Alayan 2014-05-04 14:12:27 UTC
verified in verified on ovirt-node-plugin-vdsm-0.1.1-17.el6ev.noarch

Comment 6 errata-xmlrpc 2014-06-09 14:26:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0673.html


Note You need to log in before you can comment on or make changes to this bug.