Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1054080 - gracefully warn about unsupported upgrade from legacy releases
Summary: gracefully warn about unsupported upgrade from legacy releases
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Tareq Alayan
URL:
Whiteboard: integration
Depends On:
Blocks: 1024889 1069658
TreeView+ depends on / blocked
 
Reported: 2014-01-16 08:19 UTC by Sandro Bonazzola
Modified: 2014-09-09 16:03 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1069658 (view as bug list)
Environment:
Last Closed: 2014-03-31 12:31:02 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23664 None None None Never
oVirt gerrit 23665 None None None Never

Description Sandro Bonazzola 2014-01-16 08:19:01 UTC
Upgrading to 3.4.0 is supported only from 3.3.z.
Add checks for gracefully warn about unsupported upgrade from legacy releases.

Comment 1 Sandro Bonazzola 2014-01-24 14:24:20 UTC
Upgrade to 3.4.0 is allowed only from 3.3.z.

Avoid to pull in a version of ovirt-engine-setup that will
need to be downgraded in order to allow the upgrade
from a legacy version.

same will be for 3.5.0, upgrade will be allowed only from 3.4.0.

Comment 2 Sandro Bonazzola 2014-01-24 14:24:40 UTC
Upgrade to 3.4.0 is allowed only from 3.3.z.

Avoid to pull in a version of ovirt-engine-setup that will
need to be downgraded in order to allow the upgrade
from a legacy version.

same will be for 3.5.0, upgrade will be allowed only from 3.4.z.

Comment 3 Sandro Bonazzola 2014-02-10 16:20:42 UTC
(In reply to Sandro Bonazzola from comment #2)

> same will be for 3.5.0, upgrade will be allowed only from 3.4.z.

Requiring only >=3.3.2 for now: it may be possible that we'll be able to support upgrading from 3.3.2 to 3.5.0.

merged on master, pending merge on 3.4 branch

Comment 4 Sandro Bonazzola 2014-02-19 12:27:15 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 5 Tareq Alayan 2014-02-25 12:53:47 UTC
Is this possible to upgrade from 33 downsrtream to upstream? 

i think that this fix should be in downstream?

Comment 6 Sandro Bonazzola 2014-02-25 12:57:53 UTC
Tareq, I think you'll have to wait for next downstream build.

Comment 7 Tareq Alayan 2014-02-25 13:11:11 UTC
Can you change fixed in field?

Comment 8 Sandro Bonazzola 2014-02-25 13:22:34 UTC
(In reply to Tareq Alayan from comment #7)
> Can you change fixed in field?

this is an oVirt bug, if you need to test it on RHEV I'll clone this.

Comment 9 Tareq Alayan 2014-03-18 16:14:13 UTC
If this fix should go into downstream 3.4 (rhevm) please clone this issue ...

Comment 10 Sandro Bonazzola 2014-03-18 16:23:04 UTC
Tareq, already done and verified: see bug #1069658

Comment 11 Sandro Bonazzola 2014-03-31 12:31:02 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Comment 12 Itamar Heim 2014-09-09 16:03:50 UTC
*** Bug 1103938 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.