Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 10532 - RedHat 6.2 destroys Solaris x86 partition
Summary: RedHat 6.2 destroys Solaris x86 partition
Keywords:
Status: CLOSED DUPLICATE of bug 5539
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-03 03:03 UTC by Frank Liu
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-04-24 13:36:44 UTC


Attachments (Terms of Use)

Description Frank Liu 2000-04-03 03:03:54 UTC
It's a common knowledge that Solaris x86 and Linux swap have
the same partition id. RedHat 6.1 seems to be fine but yesterday
when I installed RedHat 6.2, I can no longer boot my Solaris x86
partition. During the RedHat 6.2 (I used "expert text") installation, there
is no way I can choose which of the two swap partitions (one of
which is Solaris x86 of course) I want to use, installer automatically
format(?) both paritions as linux swap.
Is there a way I can recover my Solaris x86 partition without
reinstall?

Frank

Comment 1 Frank Liu 2000-04-03 18:25:59 UTC
Just browsed through www.redhat.com and found
http://www.redhat.com/support/docs/gotchas/6.1/gotchas-6.1-4.html
it talks about this problem under item 4.12.

I am surprised to see the problem was there since 6.1 (I don't know
why I didn't noticed it) and am wondering why it isn't fixed in 6.2.
Or at least in the expert mode, it should give me a choice to use (or not use)
which swap partitions.

Frank

Comment 2 Frank Liu 2000-04-03 23:05:59 UTC
I remember it now. I had the same problem back when I was installing
redhat 6.1. I managed to recover my Solaris partition without re-installing.
I will do the same trick again and see if I can get my Solaris partition
back. Still it is bad to see a bug in 6.1 not fixed in 6.2.
By the way, I just found the same bug reported in bugzilla:
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=10001
The reason I didn't find it when I originally submitted my bug report is
because bug 10001 is marked as "CLOSED" and won't be in the search
by default. I have to explicitly check search for "CLOSED" in the "Status"
column.


Frank

Comment 3 Jay Turner 2000-04-24 13:36:59 UTC
*** This bug has been marked as a duplicate of 5539 ***


Note You need to log in before you can comment on or make changes to this bug.