Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1051804 - [5.8.7.1. Installing the Management Console] no SESSION_SECRET neither DOMAIN_SUFFIX by default in /etc/openshift/console.conf
Summary: [5.8.7.1. Installing the Management Console] no SESSION_SECRET neither DOMAIN...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 2.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Julie
QA Contact: ecs-bugs
URL:
Whiteboard:
: 1056602 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-11 17:20 UTC by Frederic Hornain
Modified: 2015-07-20 00:23 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-29 00:45:22 UTC


Attachments (Terms of Use)

Description Frederic Hornain 2014-01-11 17:20:26 UTC
Description of problem:

In the "5.8.7.1. Installing the Management Console" of the "Deployment_Guide" of "Openshift 2.0" it is mentioned we should find "SESSION_SECRET" and "SESSION_SECRET" variable in the /etc/openshift/console.conf by default. 
Which it is not the case.

Comment 2 Julie 2014-01-20 05:59:30 UTC
This section is now updated in the Deployment Guide 6.9.7.1. 

"After the Management Console is installed, configure the SESSION_SECRET setting in the /etc/openshift/console.conf, which is used for signing the Rails sessions. Run the following command to create the random string:
# openssl rand -hex 64"

Comment 4 Alex Dellapenta 2014-01-22 14:59:11 UTC
*** Bug 1056602 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.