Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1051204 - Trivial change for ppc64le in glade3 spec and fix double seperator error
Summary: Trivial change for ppc64le in glade3 spec and fix double seperator error
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glade3
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaromír Cápík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-01-09 20:39 UTC by Brent Baude
Modified: 2016-02-01 01:59 UTC (History)
4 users (show)

Fixed In Version: glade3-3.8.4-3.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-13 15:37:19 UTC


Attachments (Terms of Use)

Description Brent Baude 2014-01-09 20:39:53 UTC
On the ppc64le arch, running autoreconf without a -if results in the package failing.  Please consider this trivial change to autoreconf syntax.

diff --git a/glade3.spec b/glade3.spec
index 3577c42..21b1cf8 100644
--- a/glade3.spec
+++ b/glade3.spec
@@ -68,7 +68,7 @@ chmod 644 ./plugins/gtk+/glade-attributes.c
 chmod 644 ./plugins/gtk+/glade-attributes.h
 
 %build
-autoreconf
+autoreconf -if
 
 %configure --disable-static \
   --enable-gtk-doc \

Comment 1 Brent Baude 2014-02-20 12:25:22 UTC
Updated patch for consideration:

[baude@localhost glade3]$ git diff
diff --git a/glade3.spec b/glade3.spec
index 3577c42..7b00f33 100644
--- a/glade3.spec
+++ b/glade3.spec
@@ -9,7 +9,7 @@ URL:            http://glade.gnome.org/
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/glade3-%{version}.tar.xz
 
 Requires:      hicolor-icon-theme
-Requires:      %{name}-libgladeui = %{?epoch:%{epoch}:}:%{version}-%{release}
+Requires:      %{name}-libgladeui = %{?epoch:%{epoch}}:%{version}-%{release}
 BuildRequires: desktop-file-utils
 BuildRequires: gettext
 BuildRequires: gnome-doc-utils
@@ -68,7 +68,7 @@ chmod 644 ./plugins/gtk+/glade-attributes.c
 chmod 644 ./plugins/gtk+/glade-attributes.h
 
 %build
-autoreconf
+autoreconf -vi
 
 %configure --disable-static \
   --enable-gtk-doc \

Comment 2 Jaromír Cápík 2014-05-13 15:07:35 UTC
I'm going to apply the proposed change with one exception ...

-Requires:      %{name}-libgladeui = %{?epoch:%{epoch}}:%{version}-%{release}
+Requires:      %{name}-libgladeui = %{?epoch:%{epoch}:}%{version}-%{release}

... as this removes the extra colon at the beginning when no Epoch is defined.


Note You need to log in before you can comment on or make changes to this bug.