Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1051150 - RHEV 3.2 hypervisor setup adds ifcfg VLAN attr to NIC parent of rhevm net subint
Summary: RHEV 3.2 hypervisor setup adds ifcfg VLAN attr to NIC parent of rhevm net subint
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.4.0
Assignee: Dan Kenigsberg
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-09 18:52 UTC by Dave Sullivan
Modified: 2018-12-05 16:56 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Red Hat Enterprise Virtualization Hypervisor setup no longer sets VLAN=yes attribute in the parent physical NIC (network interface card) when the Red Hat Enterprise Virtualization Manager network is a VLAN sub-interface.
Clone Of:
Environment:
Last Closed: 2014-06-09 13:27:29 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0504 normal SHIPPED_LIVE vdsm 3.4.0 bug fix and enhancement update 2014-06-09 17:21:35 UTC
oVirt gerrit 7411 None None None Never
oVirt gerrit 24842 None None None Never

Description Dave Sullivan 2014-01-09 18:52:18 UTC
Description of problem:

At setup / addition of a hypervisor to RHEV 3.2 RHEV-M, if the rhevm network is a VLAN sub-interface the parent physical NIC will get the VLAN=yes attribute set in its /etc/sysconfig/network-scripts/ ifcfg file.


Version-Release number of selected component (if applicable):

3.2 but expected to be same problem with 3.3


How reproducible:

Seee Description above

parent physical nic should is getting VLAN=yes setting

Actual results:


Expected results:

parent physical nic should not get VLAN=yes setting


Additional info:

Not entirely sure this should be mapped against vdsm

Comment 2 Dan Kenigsberg 2014-02-18 22:49:24 UTC
There has been an old attempt to handle this in http://gerrit.ovirt.org/#/c/7411/

Comment 3 Dan Kenigsberg 2014-02-18 22:53:55 UTC
The spurious VLAN tag is annoying, but I do not see why it merits a 3.3.z-stream.

Comment 4 Dave Sullivan 2014-02-25 18:48:47 UTC
I agree with Dan that 3.4 is good for this one, as customer is aware of it and has a workaround fix.

Comment 6 Martin Pavlik 2014-03-18 16:23:29 UTC
verified with av3

no VLAN=yes for the parent interface

Comment 7 errata-xmlrpc 2014-06-09 13:27:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html


Note You need to log in before you can comment on or make changes to this bug.