Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1051035 - [host-deploy] terminate event is not received by engine although sent by host
Summary: [host-deploy] terminate event is not received by engine although sent by host
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Alon Bar-Lev
QA Contact: Tareq Alayan
URL:
Whiteboard: infra
Depends On:
Blocks: 1052137 1056572 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-09 15:27 UTC by Alon Bar-Lev
Modified: 2016-02-10 19:30 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1052137 1056572 (view as bug list)
Environment:
Last Closed:
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23102 None None None Never

Description Alon Bar-Lev 2014-01-09 15:27:29 UTC
Timing issue, not reproducible at my environment.
Reported by Piotr, tested for fix at Piotr's environment.

apache-sshd does not flush stream nor close stream after command is executed, thus java pipe is not writing information into the reader.

solution is to flush output streams post command execution.

Comment 5 Tareq Alayan 2014-02-17 09:11:11 UTC
Couldn't reproduce issue, move to verified. 

 ovirt-engine-3.4.0-0.7.beta2.el6.noarch

Comment 7 Itamar Heim 2014-06-12 14:11:37 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.