Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1049828 - [QGA] Error 1920. Service 'QEMU Guest Agent' (QEMU-GA) failed to start. Verify that you have sufficient privileges to start system services. -- QEMU guest agent -- Installation failed.
Summary: [QGA] Error 1920. Service 'QEMU Guest Agent' (QEMU-GA) failed to start. Veri...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.4.0
Assignee: Lev Veyde
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On: 990629
Blocks: 1060720 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-08 10:17 UTC by Jiri Belka
Modified: 2014-09-18 12:24 UTC (History)
11 users (show)

Fixed In Version: av1
Doc Type: Bug Fix
Doc Text:
Previously, the QEMU Guest Agent failed to start after installation on certain Windows operating systems. This happened because the VirtIO-Serial driver required to start the service cannot be loaded without a system reboot. Now, the QEMU Guest Agent installer disables the attempt to start the service following installation if the VirtIO-Serial is not loaded. After a successful reboot, the service can be started.
Clone Of:
: 1060720 (view as bug list)
Environment:
Last Closed: 2014-06-09 14:06:00 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
logs and events (deleted)
2014-01-08 10:17 UTC, Jiri Belka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0669 normal SHIPPED_LIVE rhev-guest-tools-iso bug fix and enhancement update 2014-06-09 18:02:51 UTC

Description Jiri Belka 2014-01-08 10:17:52 UTC
Created attachment 847049 [details]
logs and events

Description of problem:
During investigation of BZ990629 I found new errors related to QGA (Qemu Guest Agent) installation.

QEMU-GA service is not installed at all. But there is Qemu Guest Agent VSS Provider installed.

-%-
MSI (s) (70:70) [08:43:28:250]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
MSI (s) (70:70) [08:43:28:250]: Product: QEMU guest agent -- Error 1920. Service 'QEMU Guest Agent' (QEMU-GA) failed to start.  Verify that you have sufficient privileges to start system services.

Error 1920. Service 'QEMU Guest Agent' (QEMU-GA) failed to start.  Verify that you have sufficient privileges to start system services.
...snip...
MSI (s) (70:70) [08:43:28:281]: Note: 1: 1708 
MSI (s) (70:70) [08:43:28:281]: Note: 1: 2205 2:  3: Error 
MSI (s) (70:70) [08:43:28:281]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1708 
MSI (s) (70:70) [08:43:28:281]: Note: 1: 2205 2:  3: Error 
MSI (s) (70:70) [08:43:28:281]: Note: 1: 2228 2:  3: Error 4: SELECT `Message` FROM `Error` WHERE `Error` = 1709 
MSI (s) (70:70) [08:43:28:281]: Product: QEMU guest agent -- Installation failed.

MSI (s) (70:70) [08:43:28:281]: Windows Installer installed the product. Product Name: QEMU guest agent. Product Version: 6.5.0.5. Product Language: 1033. Installation success or error status: 1603.
-%-

Version-Release number of selected component (if applicable):
is30/tools 3.3.9/6.5.0.5

How reproducible:
100%

Steps to Reproduce:
1. install 3.3.9 on Windows 2008 32bit
2. do only one reboot (post-install reboot as you will be prompted)
3.

Actual results:
QGA is not successfully and fully installed

Expected results:
all working

Additional info:

Comment 1 Jiri Belka 2014-01-08 14:21:11 UTC
Same for w2k8 64bit, but w2k8r2 is OK.

Comment 2 Lev Veyde 2014-01-09 14:12:53 UTC
The issue seems again to be that VirtIO-Serial is not properly installed.

We need to check if Virtio-Win drivers build 74 fixes this issue.

Comment 3 Lev Veyde 2014-01-12 12:20:20 UTC
It seems that we found the potential source of the issue.

Windows Vista and W2K8 Server is supplied with KMDF v1.7 while our drivers use a more recent v1.9. Unfortunately it seems that some kernel driver uses it, and thus we can't update WDF it without performing a reboot.

Thus a VirtIO-Serial driver can't be loaded before a reboot is performed.

Current plan is to modify the Qemu GA MSI installer, to disable the attempt to start the service following installation, if the VirtIO-Serial is not installed.

Following this change we'll need to ensure that VirtIO-Serial driver loads properly on the next boot, before QemuGA service is started.

Comment 8 Jiri Belka 2014-02-25 14:22:21 UTC
ok, 3.4.1 guest tools iso.

Comment 10 errata-xmlrpc 2014-06-09 14:06:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0669.html


Note You need to log in before you can comment on or make changes to this bug.