Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1049318 - pending memory not cleared when stopping paused VM
Summary: pending memory not cleared when stopping paused VM
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Jiri Moskovcak
QA Contact: Lukas Svaty
URL:
Whiteboard: sla
: 1071640 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-07 12:20 UTC by Arik
Modified: 2016-02-10 19:42 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:27:59 UTC
oVirt Team: SLA


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25271 None MERGED engine: clear the pending memory when destroying paused VM Never

Description Arik 2014-01-07 12:20:42 UTC
Description of problem:
The pending memory which is allocated when starting VM, is not cleared when we start a VM in paused mode and the powering off the VM. Basically, the onPoweringOn event is not triggered so no one is clearing it.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Run VM in paused mode
2. When the VM reach Paused state, power off the VM
3.

Actual results:
The pending memory (in the vds_dynamic table) is not cleared

Expected results:
The pending memory that was added when the VM was run should be reduced

Additional info:

Comment 1 Itamar Heim 2014-01-12 08:41:58 UTC
setting target release to current version for consideration and review. please do not push non-RFE bugs to an undefined target release to make sure bugs are reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:26:11 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Sandro Bonazzola 2014-05-02 07:33:58 UTC
This bug is targeted to 3.4.1 but the referenced patch has not been backported to 1.1 branch. Please either re-target the BZ to 3.5.0 or backport the patch.
Moving to status POST accordingly to current status

Comment 4 Doron Fediuck 2014-06-30 14:09:58 UTC
*** Bug 1113453 has been marked as a duplicate of this bug. ***

Comment 5 Lukas Svaty 2014-07-29 14:30:22 UTC
verified in ovirt-3.5-beta2

Comment 6 Martin Sivák 2014-08-26 11:30:43 UTC
*** Bug 1071640 has been marked as a duplicate of this bug. ***

Comment 7 Sandro Bonazzola 2014-10-17 12:27:59 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.