Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1048939 - AuditLogDirector.initMomPoliciesSeverities not called
Summary: AuditLogDirector.initMomPoliciesSeverities not called
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Martin Sivák
QA Contact: Lukas Svaty
URL:
Whiteboard: sla
Depends On: 1047889
Blocks: 1067446 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-06 14:55 UTC by Martin Sivák
Modified: 2016-02-10 20:15 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1047889
: 1067446 (view as bug list)
Environment:
Last Closed:
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 22917 None None None Never

Description Martin Sivák 2014-01-06 14:55:38 UTC
+++ This bug was initially created as a clone of Bug #1047889 +++

Description of problem:

The mentioned method is never called and so Audit Log messages related to MoM do not have severity assigned.

Version-Release number of selected component (if applicable):

ovirt-engine-3.3

How reproducible:

Start the engine.

Actual results:

> 2013-12-19 00:50:10,238 WARN
> [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector]
> (http--0.0.0.0-8080-3) AuditLogType: USER_UPDATED_MOM_POLICIES not have
> severity. Assumed Normal
> 2013-12-19 00:50:10,239 WARN
> [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector]
> (http--0.0.0.0-8080-3) AuditLogType: USER_FAILED_TO_UPDATE_MOM_POLICIES not
> have severity. Assum

Expected results:

No warnings.

Comment 1 Eyal Edri 2014-02-10 09:46:25 UTC
moving to 3.3.2 since 3.3.1 was built and moved to QE.

Comment 2 Martin Sivák 2014-02-18 09:24:52 UTC
This issue was solved by changing the way we set severity to AuditLog messages. See gerrit changes http://gerrit.ovirt.org/#/c/24441/ and http://gerrit.ovirt.org/#/c/24442/.

Comment 6 Itamar Heim 2014-06-12 14:06:49 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.