Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1048596 - First VDSM verb returns blank lastClient, lastClientIface
Summary: First VDSM verb returns blank lastClient, lastClientIface
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Assaf Muller
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks: 1055557 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-01-05 16:20 UTC by Assaf Muller
Modified: 2016-02-10 19:56 UTC (History)
13 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Previously, installing a host from the engine caused the engine to send "getVdsCaps". "getVdsCaps" uses "lastClientIface" to determine where to put the management bridge ("ovirtmgmt"). Because VDSM reports the last client IP for the previous connection (not the current one), the initial connection returns "0.0.0.0". This cased a failure in the automatic creation of the management network. The first VDSM verb now returns the correct lastClient IP and the correct lastClientIface.
Clone Of:
: 1055557 (view as bug list)
Environment:
Last Closed: 2014-06-09 13:27:13 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0504 normal SHIPPED_LIVE vdsm 3.4.0 bug fix and enhancement update 2014-06-09 17:21:35 UTC
oVirt gerrit 22967 None None None Never

Description Assaf Muller 2014-01-05 16:20:44 UTC
Description of problem:
When installing a host from the engine, the engine sends a getVdsCaps which uses 'lastClientIface' to know on which device to place the management bridge ('ovirtmgmt'). However, since VDSM reports the last client IP for the *previous* connection and not the current one, the first ever connection will always return '0.0.0.0'.

How reproducible:
100%

Steps to Reproduce:
1. Install VDSM
2. Start VDSM
3. Run getVdsCaps

Actual results:
The first invocation after VDSM start will return '0.0.0.0' for lastClient, 'lo' for lastClientIface

Expected results:
First invocation, like following ones, should return the correct lastClient IP and the correct lastClientIface.

Comment 4 Martin Pavlik 2014-02-12 09:34:19 UTC
verified 

[root@dell-r210ii-07 ~]# rpm -q vdsm
vdsm-4.14.1-3.el6.x86_64


lastClient = '10.34.66.71'
lastClientIface = 'em1'

Comment 7 errata-xmlrpc 2014-06-09 13:27:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html


Note You need to log in before you can comment on or make changes to this bug.