Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1048419 - [RFE][neutron]: Config extension plugin by names
Summary: [RFE][neutron]: Config extension plugin by names
Keywords:
Status: CLOSED DUPLICATE of bug 1058221
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: unspecified
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: Upstream M3
: 5.0 (RHEL 7)
Assignee: RHOS Maint
QA Contact: Ofer Blaut
URL: https://blueprints.launchpad.net/neut...
Whiteboard: upstream_milestone_icehouse-3 upstrea...
Depends On:
Blocks: RHOS50RFE 1058221 1082450 1083800
TreeView+ depends on / blocked
 
Reported: 2014-01-04 05:03 UTC by RHOS Integration
Modified: 2016-04-26 15:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1058221 1082450 (view as bug list)
Environment:
Last Closed: 2014-06-08 11:47:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
server log , with extension_plugins and without (last) (deleted)
2014-06-01 10:49 UTC, Ofer Blaut
no flags Details

Description RHOS Integration 2014-01-04 05:03:07 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/neutron/+spec/config-plugin-by-name.

Description:

It is convenient to config extension plugins by names rather than python classes. Currently `service_plugins` contains a list of python class names of plugins:

service_plugins = neutron.services.l3_router.l3_router_plugin:L3RouterPlugin,neutron.services.firewall.fwaas_plugin:FirewallPlugin,neutron.services.loadbalancer.plugin:LoadBalancerPlugin

I suggest add a new option to load plugins, instead of use class names, simpler names can be used:

extension_plugins = l3-router, firewall, lbaas


Specification URL (additional information):

None

Comment 5 Ofer Blaut 2014-06-01 10:47:51 UTC
When using 

extension_plugins = l3-router, firewall in neutron.conf instead of 


service_plugins =neutron.services.l3_router.l3_router_plugin.L3RouterPlugin,neutron.services.firewall.fwaas_plugin.FirewallPlugin

Neutron server doesn't load drivers and FWaaS doesn't work
To reproduce:

1. Change config in neutron.conf
2. restart neutron-server
3. check server.log 
4. try to configure fwaas policy 

- neutron firewall-policy-create  test1
Created a new firewall_policy:
+----------------+--------------------------------------+


When using service_plugins  it works !!!

python-neutron-2014.1-22.el7ost.noarch

Comment 6 Ofer Blaut 2014-06-01 10:49:57 UTC
Created attachment 901201 [details]
server log , with extension_plugins  and without (last)

Comment 7 Nir Yechiel 2014-06-08 11:47:08 UTC

*** This bug has been marked as a duplicate of bug 1058221 ***


Note You need to log in before you can comment on or make changes to this bug.