Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1048195 - RuleFlow Perspective for BRMS does not support Compensation
Summary: RuleFlow Perspective for BRMS does not support Compensation
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Designer
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ER1
: 6.0.1
Assignee: Tihomir Surdilovic
QA Contact: Sona Mala
URL:
Whiteboard:
Depends On: 1058524
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-03 11:15 UTC by Sona Mala
Modified: 2014-08-06 20:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
While using the process designer, the RuleFlow Perspective in Object Library contains Compensation boundary event even though it does not support Compensation mechanism for processes. As a result, a user can model a Compensation boundary event but can not attach Compensation activity or other Compensation mechanisms. Cause: RuleFlow Perspective in Object Library contains Compensation boundary event even if it should not support Compensation mechanism for processes. Consequence: An user can model just a Compensation boundary event and he can not attach compensation activity or other compensation mechanisms. Workaround (if any): Result:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:03:45 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot of Object Library - actual and expected results (deleted)
2014-01-03 11:15 UTC, Sona Mala
no flags Details

Description Sona Mala 2014-01-03 11:15:47 UTC
Created attachment 844930 [details]
Screenshot of Object Library - actual and expected results

Description of problem:
If I am in BRMS and perspective of designer is set to RuleFlow then I am able to model Compensation boundary event, but I am not able to attach compensation activity by association flow, because it is disabled by RuleFlow perspective.

Also, I am not able to throw event which starts compensation: 
   - Compensation Intermediate Throw Event
   - Cancel End Event
   - Compensation End Event

Version-Release number of selected component (if applicable):
6.0.0 ER7 BRMS


Steps to Reproduce:
1. Open Shape Repo

Actual results:
Rule flow perspective contains just Compensation Boundary Event.


Expected results:
Option 1:
  - full support for compensation

Option 2:
  - disable Compensation Boundary Event

Option 3:
  - minimal support for compensation
      - Compensation Boundary Event
      - Association flow
      - Compensation End Event or Cancel End Event


Additional info:
For model compendation proces, the user have to switch Designer from RuleFlow to Full Perspective.

Comment 1 Kris Verlaenen 2014-01-04 02:32:15 UTC
Compensation boundary event should be disabled for the RuleFlow configuration

Comment 2 Kris Verlaenen 2014-02-07 11:47:20 UTC
Should be fixed based on BZ-1058524

Comment 3 Sona Mala 2014-02-20 13:43:33 UTC
Verified for ER1 6.0.1


Note You need to log in before you can comment on or make changes to this bug.