Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1048079 - [RFE]Better to add "--waitforcert 60" parameters into "puppet agent --test"
Summary: [RFE]Better to add "--waitforcert 60" parameters into "puppet agent --test"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1150377
Blocks: 1063962 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-01-03 05:36 UTC by haiyang,dong
Modified: 2016-02-10 20:07 UTC (History)
15 users (show)

Fixed In Version: ovirt-node-3.0.1-18.el6_5.1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 20:49:01 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description haiyang,dong 2014-01-03 05:36:33 UTC
Description of problem:
For puppet plugins of ovirt-node upstream, it has add "--waitforcert 60" parameters into "puppet agent --test" to
wait for about 60 seconds to let puppet master sign cert.
So better to add "--waitforcert 60" parameters into "puppet agent --test" for rhevh 6.5 base image.

Version-Release number of selected component (if applicable):
rhevh-6.5-20131220.0.iso
ovirt-node-3.0.1-13.el6_5.noarch

How reproducible:
always

Steps to Reproduce:
1. 
2.
3.

Actual results:


Expected results:


Additional info:

Comment 10 haiyang,dong 2014-11-13 09:16:50 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch
ovirt-node-minimizer-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch.rpm
ovirt-node-plugin-puppet-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch.rpm
ovirt-node-tools-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch.rpm

It has added "--waitforcert 60" parameters into "puppet agent --test".
so this bug has been fixed in ovirt-node-plugin-puppet-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch.rpm,
change the status into "verified".

Comment 12 errata-xmlrpc 2015-02-11 20:49:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.