Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1047522 - misleading hint when trying to update vm-pool
Summary: misleading hint when trying to update vm-pool
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: ---
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ovirt-4.0.0-alpha
: ---
Assignee: nobody nobody
QA Contact: Ilanit Stein
URL:
Whiteboard:
Depends On: 922377 1072313
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-31 14:07 UTC by Ilanit Stein
Modified: 2016-03-10 10:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-10 10:26:12 UTC
oVirt Team: Virt
ylavi: ovirt-4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

Description Ilanit Stein 2013-12-31 14:07:30 UTC
Description of problem:

For a vmpool, pinned to a certain host & all it's VMs marked as prestart, and there is not enough memory for even a single VM run,
The fields of specify host or migration options, are not editable.
Standing on the question mark in the window edit vmpool->host->start running on,
There is a message: the bellow fields cannot be edit, while VMs are not down,
but in fact, all vms in the pool are down.

Version-Release number of selected component (if applicable):
is29

How reproducible:
always

Steps to Reproduce:
1. Create a vmpool with 10 VMs of rhel 6.5 with 1024M memory.
On Host tab-> specify a specific host, and do not allow migration (pin to a certain host)
2. edit vmpool, and choose prestart 10 VMs.
3. Try to change Host configuration to any host/allow migration. 


Actual results:
Step 3 is not possible, as the host/allow migration fields are not editable.

Expected results:
Step 3 should work.

Comment 1 Omer Frenkel 2014-01-05 12:31:38 UTC
this is not a bug, since vm-pool is not editable after its created
(you can see that nothing is editable, regardless to running vms or pre-started vms)
the only change user can do to vm pool after creation is add more vms.

thus, i agree the hint there is a little misleading (this is because its the same dialog for edit vm), so im changing the bug to fix this:
the hint: "The fields under 'Start Running On' and 'Migration Options' aren't editable while the VM isn't down" under "host" tab in edit pool is misleading, since vm-pool is not editable.

Comment 2 Michal Skrivanek 2014-01-30 11:28:20 UTC
is the hint based on the VM status at all?

Any reason why the migration options are not editable? If it would apply to all VMs at once...

Comment 3 Omer Frenkel 2014-01-30 11:33:25 UTC
(In reply to Michal Skrivanek from comment #2)
> is the hint based on the VM status at all?
> 
> Any reason why the migration options are not editable? If it would apply to
> all VMs at once...

today if you would change any option in the vm-pool, it will not change the existing vms, this is why all changes are blocked.
the problem is that even if we change for all vms at once,
if one vm is running, once it will shutdown the previous configuration would be restored (as pool vms are stateless)
and we will loose this change, as today there is no option changing a snapshot.

Comment 4 Michal Skrivanek 2014-01-31 12:17:24 UTC
bug 922377 will help here, till then there's nothing feasible to do

Comment 5 Michal Skrivanek 2014-08-22 13:01:27 UTC
this bug won't fit into 3.5 release and is being deferred to a later release. If you deeply care about this bug and deserves to be re-evaluated please let me know

Comment 6 Red Hat Bugzilla Rules Engine 2015-11-30 20:43:49 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 7 Red Hat Bugzilla Rules Engine 2015-11-30 22:37:22 UTC
Bug tickets must have version flags set prior to targeting them to a release. Please ask maintainer to set the correct version flags and only then set the target milestone.


Note You need to log in before you can comment on or make changes to this bug.