Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1046592 - Storage Type "GLUSTERFS" is missing in ovirt-engine-setup
Summary: Storage Type "GLUSTERFS" is missing in ovirt-engine-setup
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup
Version: 3.3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.4.3
Assignee: Simone Tiraboschi
QA Contact: sefi litmanovich
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-12-26 09:01 UTC by Hajime Taira
Modified: 2014-10-23 17:42 UTC (History)
8 users (show)

Fixed In Version: org.ovirt.engine-root-3.4.0-16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-08 16:59:26 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26849 master MERGED packaging: setup: add glusterfs domain type Never
oVirt gerrit 27142 ovirt-engine-3.4 MERGED packaging: setup: add glusterfs domain type Never

Description Hajime Taira 2013-12-26 09:01:10 UTC
Description of problem:
GlusterFS Storage Domain is missing in ovirt-engine-setup(a.k.a. rhevm-setup)

Version-Release number of selected component (if applicable):
rhevm-setup-3.3.0-0.38.rc.el6ev.noarch

Steps to Reproduce:
1. Execute rhevm-setup command

Actual results:
    Default storage type: (NFS, FC, ISCSI, POSIXFS) [NFS]: 

Expected results:
    Default storage type: (NFS, FC, ISCSI, POSIXFS, GLUSTERFS) [NFS]:

Comment 1 Sandro Bonazzola 2014-04-14 15:09:11 UTC
Hi, thank you for the report but this is like that by design.

Gluster storage domain are available only when you answer Gluster at the question:
"Application mode (Both, Virt, Gluster)"

If you answer Gluster, the question about "Default storage type: (NFS, FC, ISCSI, POSIXFS) [NFS]:" is not asked at all.

Comment 2 Hajime Taira 2014-04-15 08:46:08 UTC
Sorry. Representation of I was bad.
I pointed out about Storage Type. I want to re-open this.

Domain Type GLUSTERFS:7 is missing in storage type list of ovirt-setup-setup.
I propose the following modifications.

***my environment checkout by rhev-3.3.1

[htaira@alien ovirt-engine.git]$ git diff
diff --git a/packaging/setup/plugins/ovirt-engine-setup/config/domain_type.py b/packaging/setup/plugins/ovirt-engine-setup/config/domain_ty
index cf85dd3..77a65c3 100644
--- a/packaging/setup/plugins/ovirt-engine-setup/config/domain_type.py
+++ b/packaging/setup/plugins/ovirt-engine-setup/config/domain_type.py
@@ -39,6 +39,7 @@ class Plugin(plugin.PluginBase):
         'fc': 2,
         'iscsi': 3,
         'posixfs': 6,
+        'glusterfs': 7,
     }
 
     def __init__(self, context):
@@ -92,7 +93,8 @@ class Plugin(plugin.PluginBase):
                         'NFS',
                         'FC',
                         'ISCSI',
-                        'POSIXFS'
+                        'POSIXFS',
+                        'GLUSTERFS'
                     ),
                     caseSensitive=False,
                     default=osetupcons.Defaults.DEFAULT_CONFIG_STORAGE_TYPE,

Comment 3 Sandro Bonazzola 2014-04-15 09:20:46 UTC
I'm fine adding that, but it will still be asked only if application mode is virt or both.

Will it work also if application mode is virt?
Are there other implications in having it set like GLUSTERFS?

Comment 4 Hajime Taira 2014-04-15 09:27:49 UTC
> I'm fine adding that, but it will still be asked only if application mode is virt or both.

I think so. I changed subject of this Bz.

Comment 5 Sandro Bonazzola 2014-04-16 12:56:23 UTC
(In reply to Hajime Taira from comment #2)
> Sorry. Representation of I was bad.
> I pointed out about Storage Type. I want to re-open this.
> 
> Domain Type GLUSTERFS:7 is missing in storage type list of ovirt-setup-setup.
> I propose the following modifications.

Patch pushed in gerrit, currently under review.

Comment 6 Allon Mureinik 2014-04-28 00:25:26 UTC
(In reply to Sandro Bonazzola from comment #3)
> I'm fine adding that, but it will still be asked only if application mode is
> virt or both.
> 
> Will it work also if application mode is virt?
> Are there other implications in having it set like GLUSTERFS?
The oVirt setup /consumes/ this storage. Exactly the same way as by choosing iSCSI you're assuming the storage admin has configures the host(s) to use iSCSI with the given details, you should be able to choose GlusterFS and assume you have Gluster storage properly configured.

Comment 7 Itamar Heim 2014-04-30 21:02:36 UTC
I think a better approach for 3.4 would be to remove the question altogether, considering these are all shared storage domain types, and 3.4 has 'shared' DC type making this question obsolete.

Comment 8 Sandro Bonazzola 2014-05-02 07:02:48 UTC
Re-opening as per comment #7

Comment 9 Simone Tiraboschi 2014-09-08 16:59:26 UTC
Now we have only shared/local types so it makes this obsoletes.
See https://bugzilla.redhat.com/show_bug.cgi?id=1138249

*** This bug has been marked as a duplicate of bug 1138249 ***


Note You need to log in before you can comment on or make changes to this bug.