Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1046065 - rhevm-dwh-setup fails with non english locale
Summary: rhevm-dwh-setup fails with non english locale
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.3.1
Assignee: Yedidyah Bar David
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-12-23 13:05 UTC by Sandro Bonazzola
Modified: 2014-09-18 12:24 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-16 07:24:26 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Sandro Bonazzola 2013-12-23 13:05:20 UTC
Running rhevm-dwh-setup wit it_IT locale (and probably any non English locale) doesn't work.

Workaround is just use en_US locale during setup.

Comment 1 Sandro Bonazzola 2014-01-10 14:38:06 UTC
on 3.4.0 we just need to check it works with otopi based implementation.
For 3.3.z we need a patch enforcing locale when running psql.

Comment 2 Sandro Bonazzola 2014-01-15 13:45:42 UTC
I tried to reproduce the issue on rhevm-dwh-3.3.0-28.el6ev.noarch and I can't reproduce it.
Closing.

Comment 3 Yaniv Lavi 2014-01-15 18:27:11 UTC
Can you try to recreate this with a localized rhev server?



Yaniv

Comment 4 Yaniv Lavi 2014-01-15 18:28:22 UTC
(In reply to Yaniv Dary from comment #3)
> Can you try to recreate this with a localized rhev server?
> 
> 
> 
> Yaniv

Iw would be good to do this with a negative flow for DWH, like putting a corrupted db script file in setup.

Comment 5 Yuko Katabami 2014-01-15 21:50:30 UTC
(In reply to Yaniv Dary from comment #3)
> Can you try to recreate this with  a localized rhev server?
> 
> 
> 
> Yaniv

Hi Yaniv,

I tested with rhevm-dwh-3.3.0-28.el6ev.noarch but it did not reproduce the error.

[root@yuko-rhevm-33 ~]# yum install @Japanese Support
Loaded plugins: product-id, security, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
qa-latest/group_gz                                       |  488 B     00:00     
No package Support available.
Nothing to do
[root@yuko-rhevm-33 ~]# yum install "@Japanese Support"
Loaded plugins: product-id, security, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Package poppler-data-0.4.0-1.el6.noarch already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package Red_Hat_Enterprise_Linux-Release_Notes-6-ja-JP.noarch 0:5-1.el6 will be installed
---> Package ipa-gothic-fonts.noarch 0:003.02-4.2.el6 will be installed
---> Package ipa-mincho-fonts.noarch 0:003.02-3.1.el6 will be installed
---> Package ipa-pgothic-fonts.noarch 0:003.02-4.1.el6 will be installed
---> Package ipa-pmincho-fonts.noarch 0:003.02-3.1.el6 will be installed
---> Package man-pages-ja.noarch 0:20100115-6.el6 will be installed
---> Package vlgothic-fonts.noarch 0:20091202-2.el6 will be installed
--> Processing Dependency: vlgothic-fonts-common = 20091202-2.el6 for package: vlgothic-fonts-20091202-2.el6.noarch
---> Package vlgothic-p-fonts.noarch 0:20091202-2.el6 will be installed
--> Running transaction check
---> Package vlgothic-fonts-common.noarch 0:20091202-2.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                                    Arch   Version        Repository
                                                                           Size
================================================================================
Installing:
 Red_Hat_Enterprise_Linux-Release_Notes-6-ja-JP
                                            noarch 5-1.el6        rhel-65  98 k
 ipa-gothic-fonts                           noarch 003.02-4.2.el6 rhel-65 3.6 M
 ipa-mincho-fonts                           noarch 003.02-3.1.el6 rhel-65 5.0 M
 ipa-pgothic-fonts                          noarch 003.02-4.1.el6 rhel-65 3.6 M
 ipa-pmincho-fonts                          noarch 003.02-3.1.el6 rhel-65 5.0 M
 man-pages-ja                               noarch 20100115-6.el6 rhel-65 5.5 M
 vlgothic-fonts                             noarch 20091202-2.el6 rhel-65 2.2 M
 vlgothic-p-fonts                           noarch 20091202-2.el6 rhel-65 2.2 M
Installing for dependencies:
 vlgothic-fonts-common                      noarch 20091202-2.el6 rhel-65  16 k

Transaction Summary
================================================================================
Install       9 Package(s)

Total download size: 27 M
Installed size: 40 M
Is this ok [y/N]: y
Downloading Packages:
(1/9): Red_Hat_Enterprise_Linux-Release_Notes-6-ja-JP-5- |  98 kB     00:01     
(2/9): ipa-gothic-fonts-003.02-4.2.el6.noarch.rpm        | 3.6 MB     00:05     
(3/9): ipa-mincho-fonts-003.02-3.1.el6.noarch.rpm        | 5.0 MB     00:11     
(4/9): ipa-pgothic-fonts-003.02-4.1.el6.noarch.rpm       | 3.6 MB     00:06     
(5/9): ipa-pmincho-fonts-003.02-3.1.el6.noarch.rpm       | 5.0 MB     00:07     
(6/9): man-pages-ja-20100115-6.el6.noarch.rpm            | 5.5 MB     00:07     
(7/9): vlgothic-fonts-20091202-2.el6.noarch.rpm          | 2.2 MB     00:04     
(8/9): vlgothic-fonts-common-20091202-2.el6.noarch.rpm   |  16 kB     00:00     
(9/9): vlgothic-p-fonts-20091202-2.el6.noarch.rpm        | 2.2 MB     00:05     
--------------------------------------------------------------------------------
Total                                           482 kB/s |  27 MB     00:57     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : vlgothic-fonts-common-20091202-2.el6.noarch                  1/9 
  Installing : vlgothic-fonts-20091202-2.el6.noarch                         2/9 
  Installing : vlgothic-p-fonts-20091202-2.el6.noarch                       3/9 
  Installing : ipa-pgothic-fonts-003.02-4.1.el6.noarch                      4/9 
  Installing : ipa-mincho-fonts-003.02-3.1.el6.noarch                       5/9 
  Installing : ipa-gothic-fonts-003.02-4.2.el6.noarch                       6/9 
  Installing : Red_Hat_Enterprise_Linux-Release_Notes-6-ja-JP-5-1.el6.noa   7/9 
  Installing : ipa-pmincho-fonts-003.02-3.1.el6.noarch                      8/9 
  Installing : man-pages-ja-20100115-6.el6.noarch                           9/9 
  Verifying  : man-pages-ja-20100115-6.el6.noarch                           1/9 
  Verifying  : ipa-pmincho-fonts-003.02-3.1.el6.noarch                      2/9 
  Verifying  : vlgothic-fonts-20091202-2.el6.noarch                         3/9 
  Verifying  : Red_Hat_Enterprise_Linux-Release_Notes-6-ja-JP-5-1.el6.noa   4/9 
  Verifying  : ipa-gothic-fonts-003.02-4.2.el6.noarch                       5/9 
  Verifying  : ipa-mincho-fonts-003.02-3.1.el6.noarch                       6/9 
  Verifying  : vlgothic-fonts-common-20091202-2.el6.noarch                  7/9 
  Verifying  : ipa-pgothic-fonts-003.02-4.1.el6.noarch                      8/9 
  Verifying  : vlgothic-p-fonts-20091202-2.el6.noarch                       9/9 

Installed:
  Red_Hat_Enterprise_Linux-Release_Notes-6-ja-JP.noarch 0:5-1.el6               
  ipa-gothic-fonts.noarch 0:003.02-4.2.el6                                      
  ipa-mincho-fonts.noarch 0:003.02-3.1.el6                                      
  ipa-pgothic-fonts.noarch 0:003.02-4.1.el6                                     
  ipa-pmincho-fonts.noarch 0:003.02-3.1.el6                                     
  man-pages-ja.noarch 0:20100115-6.el6                                          
  vlgothic-fonts.noarch 0:20091202-2.el6                                        
  vlgothic-p-fonts.noarch 0:20091202-2.el6                                      

Dependency Installed:
  vlgothic-fonts-common.noarch 0:20091202-2.el6                                 

Complete!
[root@yuko-rhevm-33 ~]# rhevm-dwh-setup
Welcome to ovirt-engine-dwh setup utility

In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]

This utility can configure a read only user for DB access. Would you like to do so? (yes|no): yes
Error: user name cannot be empty
Provide a username for read-only user : ykatabam
Provide a password for read-only user: 
Warning: Weak Password.
Re-type password: 
Should postgresql be setup with secure connection? (yes|no): yes
Creating DB...                                        [ DONE ]
Creating read-only user...                            [ DONE ]
Setting DB connectivity...                            [ DONE ]
Starting ovirt-engine...                              [ DONE ]
Starting oVirt-ETL...                                 [ DONE ]
Successfully installed rhevm-dwh.
The installation log file is available at: /var/log/ovirt-engine/rhevm-dwh-setup-2014_01_15_19_45_47.log

Comment 6 Sandro Bonazzola 2014-01-16 07:24:26 UTC
Closing this, it works for me and Yuko.


Note You need to log in before you can comment on or make changes to this bug.