Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1045686 - OSError: [Errno 2] No such file or directory: '/dev/md'
Summary: OSError: [Errno 2] No such file or directory: '/dev/md'
Keywords:
Status: CLOSED DUPLICATE of bug 980267
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d05fdfa7bb8dc298fe50e5001d8...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-21 08:04 UTC by Kerry
Modified: 2013-12-30 00:07 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-30 00:07:17 UTC


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: anaconda.log (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: environ (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: install.log (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: lsblk_output (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: nmcli_dev_list (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: os_info (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: program.log (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: storage.log (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: syslog (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details
File: ifcfg.log (deleted)
2013-12-21 08:05 UTC, Kerry
no flags Details

Description Kerry 2013-12-21 08:04:53 UTC
Description of problem:
Insert dvd into system.  (x86_64 4GB iso, not desktop)
boot to anaconda.
select install (default parameters + noselinux selinux=0)
Anaconda boots and shows the keyboard selection screen then crashes.

Version-Release number of selected component:
anaconda-20.25.15-1

The following was filed automatically by anaconda:
anaconda 20.25.15-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/mdraid.py", line 266, in name_from_md_node
    for link in os.listdir(md_dir):
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2297, in resolveDevice
    md_name = devicelibs.mdraid.name_from_md_node(devspec[5:])
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 3129, in parseFSTab
    options=options)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 3052, in findExistingInstallations
    (mounts, swaps) = parseFSTab(devicetree, chroot=ROOT_PATH)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 427, in reset
    self.roots = findExistingInstallations(self.devicetree)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 142, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 192, in run
    threading.Thread.run(self, *args, **kwargs)
OSError: [Errno 2] No such file or directory: '/dev/md'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020\x20x86_64 quiet noselinux selinux=0 BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20

Comment 1 Kerry 2013-12-21 08:05:01 UTC
Created attachment 839927 [details]
File: anaconda-tb

Comment 2 Kerry 2013-12-21 08:05:03 UTC
Created attachment 839928 [details]
File: anaconda.log

Comment 3 Kerry 2013-12-21 08:05:05 UTC
Created attachment 839929 [details]
File: environ

Comment 4 Kerry 2013-12-21 08:05:07 UTC
Created attachment 839930 [details]
File: install.log

Comment 5 Kerry 2013-12-21 08:05:09 UTC
Created attachment 839931 [details]
File: lsblk_output

Comment 6 Kerry 2013-12-21 08:05:11 UTC
Created attachment 839932 [details]
File: nmcli_dev_list

Comment 7 Kerry 2013-12-21 08:05:13 UTC
Created attachment 839933 [details]
File: os_info

Comment 8 Kerry 2013-12-21 08:05:16 UTC
Created attachment 839934 [details]
File: program.log

Comment 9 Kerry 2013-12-21 08:05:19 UTC
Created attachment 839935 [details]
File: storage.log

Comment 10 Kerry 2013-12-21 08:05:22 UTC
Created attachment 839936 [details]
File: syslog

Comment 11 Kerry 2013-12-21 08:05:24 UTC
Created attachment 839937 [details]
File: ifcfg.log

Comment 12 Kerry 2013-12-23 05:19:33 UTC
The error message mentioned "/dev/md" so I disabled the four hard drives which make up the two raid arrays in bios, then tried again.
The same problem occurs even with these drives not present.

Comment 13 Adam Williamson 2013-12-29 23:00:52 UTC
Does /etc/fstab of an existing Linux install have an entry for '/dev/md0' or something like that? It is known that anaconda crashes if you have an fstab entry that identifies an mdraid array by its device node rather than by something more reliable, like a UUID. That's https://bugzilla.redhat.com/show_bug.cgi?id=980267 . This is quite likely to be a duplicate.

Comment 14 Kerry 2013-12-30 00:01:41 UTC
Yes, I do have /dev/md0 and /dev/md1 in the fstab file.
I will change this and try again later.
Thanks.

Comment 15 Adam Williamson 2013-12-30 00:07:17 UTC
OK, for now let's call it a dupe of that bug, it seems very likely.

*** This bug has been marked as a duplicate of bug 980267 ***


Note You need to log in before you can comment on or make changes to this bug.