Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1045471 - Cannot add hypervisor host when use chinese support
Summary: Cannot add hypervisor host when use chinese support
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: x86_64
OS: Linux
high
urgent
Target Milestone: ---
: 3.4.0
Assignee: Ravi Nori
QA Contact: Tareq Alayan
URL:
Whiteboard: infra
Depends On: 1008258
Blocks: 1051051 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-12-20 14:20 UTC by Barak
Modified: 2016-02-10 19:21 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of: 1008258
: 1051051 (view as bug list)
Environment:
Last Closed: 2014-06-12 14:06:01 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 19551 None None None Never

Description Barak 2013-12-20 14:20:43 UTC
+++ This bug was initially created as a clone of Bug #1008258 +++

Description of problem:

When i add host and using chinese support, action always be failed. 

error remind: Invalid Name

How reproducible:

This is a translation error,"root"  shouldn't be translated.


Actual results:

done

Expected results:

done

Additional info:

--- Additional comment from Itamar Heim on 2013-09-16 02:09:47 EDT ---

please specify rhev-m and vdsm versions

--- Additional comment from wrongerror on 2013-09-16 03:11:42 EDT ---

webadmin version :
ovirt-engine-webadmin-portal-3.3.0-0.7.rc2.el6

vdsm version:
vdsm-cli-4.12.1-1.el6

--- Additional comment from wrongerror on 2013-09-16 03:23:28 EDT ---

This error has nothing to do with vdsm. Called by ssh connection error,because the username "root" be translated to "根目录".

Comment 3 Tareq Alayan 2014-02-25 13:12:51 UTC
Hi Ying, 

Can you please verify this?
Thanks,

Comment 4 Tareq Alayan 2014-02-25 13:15:00 UTC
Sandro, is this merged both upstream and downstream?

Comment 5 Sandro Bonazzola 2014-02-25 13:49:45 UTC
Tareq, looking at the External Trackers section I see a patch pushed to upstream gerrit so it should be both in upstream and downstream.

Comment 6 Tareq Alayan 2014-03-06 08:38:40 UTC
Hi Ying, 

Can you please verify this?
Thanks,

Comment 7 Ying Cui 2014-03-06 09:42:01 UTC
(In reply to Tareq Alayan from comment #6)
> Hi Ying, 
> 
> Can you please verify this?
> Thanks,

Hi Tareq,
  Yes, I can help to verify it, I need to install latest rhevm 3.4 build first, then I will update the bug soon(~1 day).

Thanks
Ying

Comment 8 Ying Cui 2014-03-07 09:30:09 UTC
Verified this bug on build
rhevm 3.4.0-0.3.master.el6ev
rhev-hypervisor6-6.5-20140305.0.el6ev

Test steps:
1. login webadmin portal with Chinese support.
2. Add host via RHEVM web UI.
3. The username "root" is NOT translated to "根目录".
4. Add host successful.

Comment 9 Itamar Heim 2014-06-12 14:06:01 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.