Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1044547 - reprovisioning RHEL7 system results in system without rhn-clients installed and errors in /root/ks-rhn-post.log
Summary: reprovisioning RHEL7 system results in system without rhn-clients installed a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 560
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Jiří Mikulka
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2013-12-18 14:27 UTC by Jan Hutař
Modified: 2014-10-06 13:46 UTC (History)
3 users (show)

Fixed In Version: spacewalk-java-2.0.2-56
Doc Type: Bug Fix
Doc Text:
Cause: In RHEL 7 the packages contained in the @Core package group are different from what was in @Core in RHEL 6. Consequence: Some packages, specifically wget, perl, and the rhn client tools, are not installed by default when doing a kickstart. Later parts of the kickstart require these packages to be installed, and were failing. Fix: We added the necessary packages to the list of packages that we explicitly require for RHEL 7 kickstarts. Result: Now the kickstart can proceed normally with all of the package dependencies met.
Clone Of:
Environment:
Last Closed: 2014-01-20 09:23:12 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0042 normal SHIPPED_LIVE Red Hat Satellite server bug fix update 2014-01-20 14:22:18 UTC

Description Jan Hutař 2013-12-18 14:27:33 UTC
Description of problem:
When you reprovision RHEL7 system, you get system without rhn-clients installed and errors in /root/ks-rhn-post.log


Version-Release number of selected component (if applicable):
cobbler-2.0.7-39.el6sat.noarch
spacewalk-java-2.0.2-46.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. Create KS profile with wizard, without any other touches
2. Register RHEL7 system and reprovision it


Actual results:
System without rhn-clients installed and errors in /root/ks-rhn-post.log


Expected results:
E.g. rhn_check should work on the system. No errors should be in /root/ks-rhn-post.log


Additional info:
Errors in the /root/ks-rhn-post.log file are:

/tmp/ks-script-tsy_Ns: line 102: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT: No such file or directory
/tmp/ks-script-tsy_Ns: line 103: perl: command not found
/tmp/ks-script-tsy_Ns: line 107: wget: command not found
error: File not found by glob: /tmp/rhn_rpms/optional/pyOpenSSL*
error: File not found by glob: /tmp/rhn_rpms/optional/rhnlib*
error: File not found by glob: /tmp/rhn_rpms/optional/libxml2-python*
error: File not found by glob: /tmp/rhn_rpms/optional/libxml2*
/tmp/ks-script-tsy_Ns: line 109: perl: command not found
cp: cannot stat '/tmp/ks-tree-copy/*': No such file or directory
/tmp/ks-script-tsy_Ns: line 122: wget: command not found
/tmp/ks-script-tsy_Ns: line 123: perl: command not found
/tmp/ks-script-tsy_Ns: line 135: rhnreg_ks: command not found
/tmp/ks-script-tsy_Ns: line 141: rhn_check: command not found

Comment 1 Jan Hutař 2013-12-18 14:37:21 UTC
One symptom of this bug might be this (if not, I have to create extra bug-report):

When reprovisioning RHEL7 system and following provisioning status on Systems -> <system> -> Provisioning -> Kickstart -> Session Status, "Kickstart complete" is never marked as done even when system was already reinstalled.

Comment 2 Stephen Herr 2013-12-18 15:13:48 UTC
Ah, this is because the rpms installed by default have changed in RHEL 7. I'll have to add perl, wget, and the rhn client tools to the list of packages we tell it to install for RHEL 7 kickstarts. And yes, this problem would also cause the "Kickstart complete" symptom.

Comment 3 Stephen Herr 2013-12-18 21:00:41 UTC
Committed to Spacewalk master:
02b94a12c35b7b63de4cc62326a6263d6251a950

Comment 5 Stephen Herr 2014-01-03 14:50:39 UTC
And:
8834581f30ade1e96838907e7b51e1ea14c6a2d0

Comment 10 errata-xmlrpc 2014-01-20 09:23:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0042.html


Note You need to log in before you can comment on or make changes to this bug.