Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1040938 - [DWH-SETUP] - remote user password is asked twice for authentication
Summary: [DWH-SETUP] - remote user password is asked twice for authentication
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: unspecified
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 3.4.0
Assignee: Yedidyah Bar David
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: 1057281 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-12-12 11:33 UTC by Barak Dagan
Modified: 2014-09-18 12:24 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Previously, users were asked to provide their passwords twice when running ovirt-engine-dwh-setup with a remote database. Now, users are only asked to provide their password one time.
Clone Of:
: 1052065 1057281 (view as bug list)
Environment:
Last Closed: 2014-06-09 15:16:20 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0601 normal SHIPPED_LIVE rhevm-dwh 3.4 bug fix and enhancement update 2014-06-09 19:15:53 UTC
oVirt gerrit 23187 None None None Never

Description Barak Dagan 2013-12-12 11:33:20 UTC
Description of problem:
During installation of DWH, using remote DB configuration, user is asked twice for the password :

Please choose a password for the db user: 
Warning: Weak Password.
Re-type password: 
Creating DB...                                        [ DONE ]
Setting DB connectivity...                            [ DONE ]

This behaviour is generally used, when an account is created and not for authentication

Version-Release number of selected component (if applicable):
IS26

How reproducible:
100%

Steps to Reproduce:
1. install engine using remote db configuration
2. install dwh using the same remote db server
3.

Actual results:
1) Password is asked twice
2) There is password strength calculation
3) Getting the impression that the db is created by the setup

Expected results:
1) Password will be asked once
2) More accurate message than creating DB

Additional info:

Comment 1 Sandro Bonazzola 2014-01-10 14:39:55 UTC
Didi can you rebase and verify Alex patch?

Comment 3 Jiri Belka 2014-02-18 17:20:49 UTC
ok, ovirt-engine-dwh-setup-3.4.0-0.2.master.20140205160753.el6.noarch ovirt-engine-setup-3.4.0-0.7.beta2.el6.noarch

...
         
          DWH database host [localhost]: jb-rh32.rhev.lab.eng.brq.redhat.com
          DWH database port [5432]: 
          DWH database secured connection (Yes, No) [No]: 
          DWH database name [ovirt_engine_history]: engine_history
          DWH database user [ovirt_engine_history]: engine_history
          DWH database password: 
          Where is the Reports database located? (Local, Remote) [Local]: Remote
...

Comment 4 errata-xmlrpc 2014-06-09 15:16:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0601.html


Note You need to log in before you can comment on or make changes to this bug.