Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1039231 - BCM57780 is getting disabled with RHEV-H 6.5(20131127.0.el6)
Summary: BCM57780 is getting disabled with RHEV-H 6.5(20131127.0.el6)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: All
OS: All
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: GSS_RHEV_33_BETA rhevh-for-rhev-3.3 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-12-07 06:56 UTC by Ranjith Rajaram
Modified: 2016-02-10 20:11 UTC (History)
23 users (show)

Fixed In Version: rhev-hypervisor6-6.6-20141218.0.iso rhev-hypervisor7-7.0-20141218.0.iso
Doc Type: Enhancement
Doc Text:
Support for Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe has been added to the Red Hat Enterprise Virtualization Hypervisor.
Clone Of:
Environment:
Last Closed: 2015-02-11 20:48:08 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 28155 None None None Never

Description Ranjith Rajaram 2013-12-07 06:56:28 UTC
Description of problem:

System: Dell T1500

RHEV-Hypervisor install disables the onboard NIC

02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)

Message:

tg3.c:v3.132 (May 21, 2013)
tg3 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
tg3 0000:02:00.0: setting latency timer to 64
tg3 mdio bus: probed
tg3 0000:02:00.0: No PHY devices
tg3 0000:02:00.0: Problem fetching invariants of chip, aborting
tg3 0000:02:00.0: PCI INT A disabled


While on the same box, RHEL 6.5 works

tg3.c:v3.132 (May 21, 2013)
tg3 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
tg3 0000:02:00.0: setting latency timer to 64
tg3 mdio bus: probed
tg3 0000:02:00.0: eth0: Tigon3 [partno(BCM57780) rev 57780001] (PCI Express) MAC address a4:ba:db:fc:71:a9
tg3 0000:02:00.0: eth0: attached PHY driver [Broadcom BCM57780] (mii_bus:phy_addr=200:01)
tg3 0000:02:00.0: eth0: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] TSOcap[1]
tg3 0000:02:00.0: eth0: dma_rwctrl[76180000] dma_mask[64-bit]
tg3 0000:02:00.0: irq 33 for MSI/MSI-X
tg3 0000:02:00.0: p128p1: Link is down
tg3 0000:02:00.0: p128p1: Link is up at 1000 Mbps, full duplex
tg3 0000:02:00.0: p128p1: Flow control is off for TX and off for RX


Version-Release number of selected component (if applicable):
RHEV-H 6.5(20131127.0.el6)

How reproducible:

Always

Steps to Reproduce:
1. Install RHEV-H 6.5
2. Onboard nic fails to be shown in network section while configuring the box


Actual results:

NIC is disabled with RHEVH. While the same NIC works with RHEL 6.5


Expected results:

NIC should be detected


Additional info:

1. dmesg from RHEL 6.5 is attached [File also contains lspci output] Name: dmesg-rhel65.txt
2. dmidecode from 6.5 is attached Name: rhel6.5dmi.txt
3. dmesg from RHEV-H 6.5 [File also containts lspci output] name: dmesg.txt
4. dmidecode is also attached dmirhevh.txt

Comment 4 Fabian Deutsch 2013-12-10 12:38:11 UTC
Ranjith,

is the NIC shown in the NIC list of

ip link

or

ifconfig

?

And could you please check if 

modprobe broadcom
modprobe tg3

are loaded correctly?

Comment 6 Ranjith Rajaram 2013-12-10 12:48:35 UTC
Fabian

if the NIC is disabled (PCI INT A disabled), then the NIC will not be visible any of the ip commands

Module was loaded properly at the time of boot

If you look at the dmesg output, the same module is used for detecting 

I should be able to provide access to this box by Monday or Tuesday.

I am not un-setting the needinfo

Comment 8 Fabian Deutsch 2013-12-19 10:42:54 UTC
Hey,

could you please check if the kernel versions of the RHEL and RHEV-H you tested differ?

Comment 9 Ranjith Rajaram 2013-12-19 10:54:35 UTC
Fabian

I have attached dmesg for you perusal when I opened this BZ. That should have the kernel information that you require.

I will get back to you with the reproducer. Please note I will not be able to set up a KVM/remote access. 

Ranjith

Comment 10 Fabian Deutsch 2013-12-20 07:33:28 UTC
Hey Ivan,

as you seem to handle some tg3 related bugs - is this a known problem (I've seen similar reports in bz). And do you know if there is a solution for this?

Comment 14 Fabian Deutsch 2014-02-14 10:09:52 UTC
Ranjith,

could you please see if this problem still appears with the latest RHEV-H build?

Comment 15 Ranjith Rajaram 2014-02-28 05:01:37 UTC
Fabian

I am working to get access to the hardware. will update the BZ

Comment 16 Ying Cui 2014-03-11 07:14:08 UTC
 (In reply to Ranjith Rajaram from comment #15)
> Fabian
> 
> I am working to get access to the hardware. will update the BZ

Hi Ranjith,
  Any update here with latest RHEV-H build?
  As QE did not have such hardware(NIC BCM57780), and can not reproduce this bug on QE's environment, see comment 13, so can you help to verify this bug if the bug is fixed? Thanks.

Ying

Comment 17 Ying Cui 2014-05-09 01:26:08 UTC
Got email reply by Ranjith on May 07, Ranjith will get access on the box on May 18, test RHEV 3.4 and will update the BZ with the results.

Thanks
Ying

Comment 18 Doron Fediuck 2014-05-22 12:26:34 UTC
(In reply to Ying Cui from comment #17)
> Got email reply by Ranjith on May 07, Ranjith will get access on the box on
> May 18, test RHEV 3.4 and will update the BZ with the results.
> 
> Thanks
> Ying

Any updates?

Comment 19 Ranjith Rajaram 2014-05-24 10:19:21 UTC
Tried  Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140408.0.el6ev)
Did not fix. 

Attached the dmesg.txt file

Comment 21 Ranjith Rajaram 2014-05-24 11:55:27 UTC
Tried with

Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140501.1.el6ev)

I still see the bug. 

dmesg attached

Comment 23 Fabian Deutsch 2014-05-26 21:49:26 UTC
Hey Ranjith,

can you tell or test if this bug is also reproducable on RHEL?

Comment 24 Ranjith Rajaram 2014-05-27 10:51:58 UTC
Fabian

This issue is not reproducible when RHEL is used. 

Please check the BZ problem description/Comment #0 and check comment #12

Thanks

Comment 25 Ivan Vecera 2014-05-27 10:56:53 UTC
Hi Fabian & Ranjith,
it seems you are loading tg3 module without broadcom module. The BCM57780 uses broadcom phylib module (broadcom.ko) that needs to be loaded prior loading of tg3 module, otherwise tg3 won't detect any PHY.
The broadcom.ko module should be loaded automatically, but please check if it is present in installation image or initramfs. IMHO RHEV-H installation initramfs contains tg3.ko module but not broadcom.ko module.

Comment 26 Joey Boggs 2014-05-27 17:57:43 UTC
http://gerrit.ovirt.org/28155

Adds broadcom module into initramfs enabling the nic to correctly initialize

Here's a test build with it loaded in the initramfs:

http://jenkins.virt.bos.redhat.com/jenkins/job/rhev-hypervisor-
6/lastSuccessfulBuild/artifact/rhev-hypervisor6-6.5-20140317.0.auto2886.el6.iso

Comment 27 Ranjith Rajaram 2014-05-28 10:28:15 UTC
Hello All

Tried the iso referred in #26.

It fixes the problem

Thanks

Comment 29 Fabian Deutsch 2014-07-24 16:02:36 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 38 Ying Cui 2015-01-26 07:12:43 UTC
Fabian, this bug was verified on rhevh 6.6 for 3.5 build see comment 33.
Do you think we need to request Ranijth to test this bug on rhevh 7.0 for 3.5 as well?
This bug's patch http://gerrit.ovirt.org/#/c/28155/ , probably we can safe to verify it only according to comment 33, no need rhevh 7.0 for 3.5 testing for this bug.

Comment 39 Fabian Deutsch 2015-01-26 09:21:51 UTC
(In reply to Ying Cui from comment #38)
> Fabian, this bug was verified on rhevh 6.6 for 3.5 build see comment 33.
> Do you think we need to request Ranijth to test this bug on rhevh 7.0 for
> 3.5 as well?

No. I is alright to verify it on 3.5-6.6 only.

Comment 40 Ying Cui 2015-01-26 12:30:34 UTC
OK, after QE and DEV all agree, and time is tight for rhev 3.5.0 GA, so we will only verify this bug on rhevh 6.6 for rhev 3.5 according to comment 33, comment 38 and comment 39.

But if Ranijth can provide more testing for comment 37 before RHEV 3.5.0 GA, that could be great.

Comment 42 errata-xmlrpc 2015-02-11 20:48:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.