Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1039 - lpd denies service
Summary: lpd denies service
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lpr
Version: 5.2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-04 15:20 UTC by mike
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-02-17 17:08:34 UTC


Attachments (Terms of Use)

Description mike 1999-02-04 15:20:56 UTC
I have printcap entries setup (via the print tool) on my
RH5.2 machine for various printers.  I have allowed other
machines (via /etc/hosts.lpd) to print to this machine.
There is no 'rs' entry in the printcap file.

If the external user printing to the print spool (RH5.2)
machine does not have an account on it, the print job fails
because (according to the log in 'messages') it cannot fork -
user unknown.

This behavior is incorrect, unless there is an RS entry in
the printcap for the printer.

The problem is a bug in the lpd code, in printjob.c.  There
are two tests of the 'RS' variable where there is a missing
'else' branch to copy a valid username into the 'logname'
variable.  In both cases, the code should look like:

if( RS ) {
   do some stuff...
}
else
   strcpy( logname, "lp" );

Comment 1 David Lawrence 1999-02-07 00:52:59 UTC
i have verified this to be true.

Comment 2 Bill Nottingham 1999-02-17 17:08:59 UTC
fixed in lpr-0.34-1

Comment 3 jefft 1999-03-02 05:42:59 UTC
Glad to see this has been fixed, however, I can't find the update for
lpr-0.34-1. Where can I download this fix? Thanks.


Note You need to log in before you can comment on or make changes to this bug.