Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1038952 - [RHEVM-SDK-PYTHON] sdk ignores url attribute and hardcode /api
Summary: [RHEVM-SDK-PYTHON] sdk ignores url attribute and hardcode /api
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Juan Hernández
QA Contact: sefi litmanovich
URL:
Whiteboard: infra
Depends On:
Blocks: 961677 1053542 1057367 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-12-06 08:52 UTC by Alon Bar-Lev
Modified: 2016-02-10 19:24 UTC (History)
12 users (show)

Fixed In Version: rhevm-sdk-python-3.4.0.3-1
Doc Type: Bug Fix
Doc Text:
Previously, the '/api' path was hard-coded into the Python SDK for Red Hat Enterprise Virtualization. Now, this path is no longer hard-coded, and users must supply a URL that is then parsed by the SDK to determine the supplied path, providing greater flexibility for accessing resources using the Python SDK.
Clone Of:
Environment:
Last Closed: 2014-06-09 13:43:03 UTC
oVirt Team: Infra


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0657 normal SHIPPED_LIVE rhevm-sdk-python bug fix and enhancement update 2014-06-09 17:42:29 UTC
oVirt gerrit 22460 None None None Never
oVirt gerrit 23368 None None None Never

Description Alon Bar-Lev 2013-12-06 08:52:44 UTC
https://gerrit.eng.lab.tlv.redhat.com/gitweb?p=rhevm-sdk.git;a=blob;f=src/ovirtsdk/api.py;h=9d030855e30a3931b9921e9b2b231163b9192f15;hb=refs/heads/rhev-3.3#l125
http://gerrit.ovirt.org/gitweb?p=ovirt-engine-sdk.git;a=blob;f=src/ovirtsdk/api.py;h=d43099ac5e92714e910651160af969f03b18085b;hb=HEAD#l129

125         # Get entry point
126         entry_point = proxy.request(
127             method='GET',
128             url='/api'
129         )

Not sure about the java sdk it was too complex for me to chase the sequence.

Comment 1 Michael Pasternak 2013-12-06 17:12:38 UTC
(In reply to Alon Bar-Lev from comment #0)
> https://gerrit.eng.lab.tlv.redhat.com/gitweb?p=rhevm-sdk.git;a=blob;f=src/
> ovirtsdk/api.py;h=9d030855e30a3931b9921e9b2b231163b9192f15;hb=refs/heads/
> rhev-3.3#l125
> http://gerrit.ovirt.org/gitweb?p=ovirt-engine-sdk.git;a=blob;f=src/ovirtsdk/
> api.py;h=d43099ac5e92714e910651160af969f03b18085b;hb=HEAD#l129
> 
> 125         # Get entry point
> 126         entry_point = proxy.request(
> 127             method='GET',
> 128             url='/api'
> 129         )
> 
> Not sure about the java sdk it was too complex for me to chase the sequence.

thanks alon!

Comment 4 Yedidyah Bar David 2014-01-16 15:06:19 UTC
engine-setup nightly with all-in-one, which uses '/ovirt-engine/api' fails.

A testcase in which I changed the call to '/api' fixed it.

Comment 6 Yedidyah Bar David 2014-01-16 15:25:56 UTC
*** Bug 1053542 has been marked as a duplicate of this bug. ***

Comment 8 sefi litmanovich 2014-03-03 12:53:06 UTC
Verified.

reproduced with ovirt 3.4 ovirt-engine-3.4.0-0.11.beta3.el6.noarch with ovirt-engine-sdk-python-3.4.0.2-1.el6.noarch

verified with ovirt 3.4 ovirt-engine-3.4.0-0.11.beta3.el6.noarch with ovirt-engine-sdk-python-3.4.0.4-1.el6.noarch

Comment 10 errata-xmlrpc 2014-06-09 13:43:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0657.html


Note You need to log in before you can comment on or make changes to this bug.