Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1038613 - XP VMs get virtio-scsi controller when created as a brand-new VM or from template
Summary: XP VMs get virtio-scsi controller when created as a brand-new VM or from temp...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Daniel Erez
QA Contact: Raz Tamir
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-12-05 13:36 UTC by David Jaša
Modified: 2016-02-10 20:27 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 22648 None None None Never
oVirt gerrit 22649 None None None Never
oVirt gerrit 23860 None None None Never
oVirt gerrit 23861 None None None Never

Description David Jaša 2013-12-05 13:36:45 UTC
Description of problem:
VM of Windows XP type gets virtio-scsi controller when created as a brand-new VM or from template. VMs created in earlier RHEV builds don't have this issue. The device is added by engine because vmCreate received by vdsm contains this device:
{'device': 'scsi', 'specParams': {}, 'model': 'virtio-scsi', 'type': 'controller', 'deviceId': 'dde43c41-8479-476b-959c-3c5493a9e39d'}
The issue is cosmetic but ugly - device manager shows a device with yellow exclamation mark and you can't get a driver for it.

Version-Release number of selected component (if applicable):
is25 / rhevm-backend-3.3.0-0.37.beta1.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1. create a VM of Windows XP OS Type
2. run the VM
3. look at its domain xml (or to vdsm logs at its vmCreate command)

Actual results:
vmCreate contains entry as above
domain xml contains device:
    <controller type='scsi' index='0' model='virtio-scsi'>
      <alias name='scsi0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    </controller>

Expected results:
virtio-scsi is not added to Windows XP VMs (or VMs of any type lacking virtio-scsi driver)

Additional info:
VMs created in earlier builds are not affected

Comment 5 Raz Tamir 2014-02-17 15:15:34 UTC
verified - followed the steps to reproduce
ovirt-engine-3.4.0-0.7.beta2.el6.noarch
vdsm-4.14.1-3.el6.x86_64

Comment 7 Itamar Heim 2014-06-12 14:07:19 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.