Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 103827 - installation hang up after checking hard disk blocks
Summary: installation hang up after checking hard disk blocks
Keywords:
Status: CLOSED DUPLICATE of bug 66181
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-05 13:45 UTC by Need Real Name
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:28 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-09-05 13:45:52 UTC
Description of problem:  anaconda fails to install rpms after checking the hard disk blocks  Version-Release number of selected component (if applicable): Red Hat 7.3 linux installation disk  How reproducible: choose in the menu of diskdruid : "check the blocks disk before installing"  (on a new empty disk) and this for all partitions you  create.  Steps to Reproduce: 1. 2. 3.      Actual results:  Hang up installation with nothing done, after one hour checking disk (80MB), and one hour for me to choose precisely the rpm to install ...   Expected results: Correct installation !   Additional info: see the dump produced by anaconda itself

Comment 1 Mike McLean 2003-09-05 15:33:28 UTC
Reporter writes:

Raphael Astier wrote:
> Hello.
> This bug makes me lost 2 hours.
> I will appreciate if I could obtain some explanations about it.
> 
> Thank you
> 
> ------------------------------------------------------------------------
> 
> Traceback (innermost last):
>   File "/usr/bin/anaconda", line 633, in ?
>     intf.run(id, dispatch, configFileData)
>   File "/usr/lib/anaconda/gui.py", line 353, in run
>     self.icw.run (self.runres, configFileData)
>   File "/usr/lib/anaconda/gui.py", line 814, in run
>     mainloop ()
>   File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
>     _gtk.gtk_main()
>   File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
>     self.currentWindow.renderCallback()
>   File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
>     self.intf.icw.nextClicked()
>   File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
>     self.dispatch.gotoNext()
>   File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
>     self.moveStep()
>   File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
>     rc = apply(func, self.bindArgs(args))
>   File "/usr/lib/anaconda/packages.py", line 375, in turnOnFilesystems
>     thefsset.checkBadblocks(instPath)
>   File "/usr/lib/anaconda/fsset.py", line 1007, in checkBadblocks
>     self.badblocksEntry(entry, chroot)
>   File "/usr/lib/anaconda/fsset.py", line 984, in badblocksEntry
>     entry.fsystem.badblocksDevice(entry, self.progressWindow, chroot)
>   File "/usr/lib/anaconda/fsset.py", line 210, in badblocksDevice
>     l = string.split(num, '/')
> TypeError: argument 1: expected read-only character buffer, int found
> 

Comment 2 Mike McLean 2003-09-05 15:45:38 UTC
This is a well known problem that was fixed in later releases.  If you insist on
using 7.3 there is a simple workaround: don't ask anaconda to check for badblocks.

The traceback you encountered only occurs when bad blocks are actually found, so
you should consider that fact before continuing to use the drive.

*** This bug has been marked as a duplicate of 66181 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:58:28 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.