Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1036652 - Apply upstream patch to prevent rgmanager crash on misconfigured "time_t" values (e.g., __restart_expire_time) in cluster.conf
Summary: Apply upstream patch to prevent rgmanager crash on misconfigured "time_t" val...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rgmanager
Version: 6.4
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-02 12:40 UTC by Jan Pokorný [poki]
Modified: 2017-01-17 21:06 UTC (History)
2 users (show)

Fixed In Version: rgmanager-3.0.12.1-20.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 08:12:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1586 normal SHIPPED_LIVE rgmanager bug fix and enhancement update 2014-10-14 01:27:08 UTC
Red Hat Bugzilla 1414139 None None None Never

Internal Links: 1414139

Description Jan Pokorný [poki] 2013-12-02 12:40:27 UTC
Looks like relatively old upstream commit [1] hasn't reached RHEL
downstream yet.  Note that the respective bug/fix was also discussed
in the security context as of its time (that's why medium pri/sev);
reproducer example from the original discussion involving me, Lon, Ryan,
and secalert@ (test-expand-time is the part of the patch, and can be
compiled separately in order to test verify the issue):

> Btw. here is a demonstration of the issue with the test program      
> that was part of the posted patch (but here resrules.c is unpatched):
>                                                                      
> $ ./test-expand-time                                                 
> Time string: 0                                                       
> Expanded   : 0                                                       
> Time string: 000000000000000                                         
> Expanded   : 0                                                       
> Time string: 0000000000000000                                        
> Expanded   : 0                                                       
> Time string: 00000000000000000                                       
> Expanded   : 0                                                       
> Time string: 000000000000000000                                      
> Expanded   : 0                                                       
> Time string: 0000000000000000000                                     
> Expanded   : 0                                                       
> Time string: 00000000000000000000                                    
> Expanded   : 0                                                       
> Time string: 000000000000000000000                                   
> Expanded   : 0                                                       
> Time string: 0000000000000000000000                                  
> Expanded   : 0                                                       
> Time string: 00000000000000000000000                                 
> Expanded   : 0                                                       
> Time string: 000000000000000000000000                                
> Expanded   : 0                                                       
> Time string: 0000000000000000000000000                               
> Expanded   : 0                                                       
> Segmentation fault                                                   

This should definitely go into 6.6.

[1] https://git.fedorahosted.org/cgit/cluster.git/commit/?id=9d0ecbac1ff8ac1f045bd19bb73ca063a5351014

Comment 3 errata-xmlrpc 2014-10-14 08:12:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1586.html


Note You need to log in before you can comment on or make changes to this bug.