Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1035825 - Collect ovirt-engine runtime configuration files
Summary: Collect ovirt-engine runtime configuration files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector
Version: 3.2.0
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Petr Beňas
URL:
Whiteboard: integration
Depends On: 1052854
Blocks: 1060673 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-11-28 15:09 UTC by Lee Yarwood
Modified: 2018-12-04 16:32 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Previously, the rhevm-log-collector utility did not collect Red Hat Enterprise Virtualization Manager runtime configuration files. Now, these files are collected.
Clone Of:
: 1060673 (view as bug list)
Environment:
Last Closed: 2014-06-09 14:06:07 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0668 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2014-06-09 18:03:59 UTC
oVirt gerrit 21864 None None None Never
oVirt gerrit 23943 None None None Never
oVirt gerrit 23987 None None None Never

Description Lee Yarwood 2013-11-28 15:09:29 UTC
Description of problem:
Collect ovirt-engine logging configuration files engine-service.xml.in & engine-service-logging.properties.in

Version-Release number of selected component (if applicable):
rhevm-log-collector-3.2.2-4.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Collect a full RHEV-M log collector.
2. engine-service.xml.in & engine-service-logging.properties.in are not collected.
3.

Actual results:
engine-service.xml.in & engine-service-logging.properties.in are not collected.

Expected results:
engine-service.xml.in & engine-service-logging.properties.in are collected.

Additional info:

Comment 1 Sandro Bonazzola 2013-11-29 12:31:20 UTC
(In reply to Lee Yarwood from comment #0)
> Description of problem:
> Collect ovirt-engine logging configuration files engine-service.xml.in &
> engine-service-logging.properties.in
> 

Aren't those files just templates? Why do you need them?

Comment 2 Lee Yarwood 2013-11-29 14:11:30 UTC
(In reply to Sandro Bonazzola from comment #1)
> (In reply to Lee Yarwood from comment #0)
> > Description of problem:
> > Collect ovirt-engine logging configuration files engine-service.xml.in &
> > engine-service-logging.properties.in
> > 
> 
> Aren't those files just templates? Why do you need them?

Correct, these are templates but the logging configuration within these files is static and not updated by the ovirt-engine service script. We could fetch the complete configuration files from /var/tmp/ovirt-engine/ if you feel it makes more sense.

Comment 3 Sandro Bonazzola 2013-11-29 14:14:44 UTC
(In reply to Lee Yarwood from comment #2)

> > Aren't those files just templates? Why do you need them?
> 
> Correct, these are templates but the logging configuration within these
> files is static and not updated by the ovirt-engine service script. We could
> fetch the complete configuration files from /var/tmp/ovirt-engine/ if you
> feel it makes more sense.

/var/tmp/ovirt-engine/config/

sounds better to me (should reflect the configuration really used right?)

Comment 5 Sandro Bonazzola 2014-02-03 10:19:52 UTC
merged on upstream master, pushed to 3.4 branch.

Comment 6 Sandro Bonazzola 2014-02-03 10:21:04 UTC
merged on upstream 3.4 branch.

Comment 8 Petr Beňas 2014-02-25 10:09:02 UTC
Verified in ovirt-log-collector-3.4.0-0.5.beta3.el6.noarch.

[root@pb-rh34 tmp]# tar -tf sosreport-LogCollector-20140224142931.tar | grep '/var/tmp/ovirt-engine'
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/ovirt-engine_history/
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/ovirt-engine_history/ovirt-engine.last.xml
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/ovirt-engine_history/ovirt-engine.initial.xml
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/ovirt-engine_history/current/
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/ovirt-engine_history/current/ovirt-engine.v1.xml
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/ovirt-engine_history/ovirt-engine.boot.xml
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/ovirt-engine-logging.properties
./pb-rh34-2014022414261393248410/var/tmp/ovirt-engine/config/ovirt-engine.xml

Comment 10 errata-xmlrpc 2014-06-09 14:06:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0668.html


Note You need to log in before you can comment on or make changes to this bug.