Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1035395 - /etc/pki/libvirt-spice does not exist when starting manager VM. Setup fails with an SSL error.
Summary: /etc/pki/libvirt-spice does not exist when starting manager VM. Setup fails w...
Keywords:
Status: CLOSED DUPLICATE of bug 1034634
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3.0
Assignee: Sandro Bonazzola
QA Contact: Leonid Natapov
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-27 16:25 UTC by Andrew Dingman
Modified: 2013-12-10 14:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-10 14:12:39 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Andrew Dingman 2013-11-27 16:25:54 UTC
Description of problem:

When running "hosted-engine --deploy" and choosing a Spice console, the installation fails with an SSL error.

Logfile vdsm.log shows an error "vdsm.log:((null):4659): Spice-Warning **: reds.c:3256:reds_init_ssl: Could not load certificates from /etc/pki/libvirt-spice/server-cert.pem". The referenced directory /etc/pki/libvirt-spice does not exist.


Version-Release number of selected component (if applicable):

ovirt-hosted-engine-setup-1.0.0-0.9.beta4.el6ev.noarch from is24.2


How reproducible: always


Steps to Reproduce:
1. run 'hosted-engine --deploy'
2. choose a spice console
3. encounter error

Actual results:

VM creation fails with an SSL error on the terminal and the log message listed above.

Expected results:

VM is created and a remote-viewer connection is possible.

Additional info:

If the option to use spice were not offered, I'd consider this an RFE rather than a bug as such.

Comment 2 Itamar Heim 2013-12-08 09:03:10 UTC
doron - dup of bug 1034679?

Comment 3 Sandro Bonazzola 2013-12-10 14:12:39 UTC
(In reply to Itamar Heim from comment #2)
> doron - dup of bug 1034679?

yes, or better, dup of bug #1034634.

*** This bug has been marked as a duplicate of bug 1034634 ***


Note You need to log in before you can comment on or make changes to this bug.