Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1035 - assert fails in telnet when given a very long line.
Summary: assert fails in telnet when given a very long line.
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: telnet
Version: 5.1
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
Depends On:
TreeView+ depends on / blocked
Reported: 1999-02-04 08:12 UTC by Aleksey Nogin
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 1999-04-07 21:06:08 UTC

Attachments (Terms of Use)

Description Aleksey Nogin 1999-02-04 08:12:48 UTC
When I ran

(echo "something"; cat some_file) | telnet some_host

I've got (after some time):

telnet: buffer overflow, losing data, sorry
telnet: int ringbuf::flush(): Assertion
`((size+head-tail)%size)==count' failed.
Abort (core dumped)

some_file has a line about 400Kb long.
The bug is 100% reproducable
I run RedHat 5.1 + all updates.

Comment 1 Jeff Johnson 1999-04-07 21:06:59 UTC
Fixed (by scrapping th C++ telnet client in favor of the OpenBSD
client) in telnet-0.10-25.

Note You need to log in before you can comment on or make changes to this bug.