Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1034774 - kvm: increase Virtual Memory default for rhel7 ks tree (otherwise OOM)
Summary: kvm: increase Virtual Memory default for rhel7 ks tree (otherwise OOM)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Jiří Mikulka
URL:
Whiteboard:
: 1039192 (view as bug list)
Depends On:
Blocks: sat560-triage 1039193
TreeView+ depends on / blocked
 
Reported: 2013-11-26 13:37 UTC by Lukas Pramuk
Modified: 2014-10-06 13:45 UTC (History)
6 users (show)

Fixed In Version: spacewalk-java-2.0.2-56
Doc Type: Bug Fix
Doc Text:
Cause: RHEL 7's Anaconda installer requires at least 768 MB of ram to complete the installation. Default ram allotment for virtual machines has always been 512 MB in Satellite. Consequence: Attempting to provision a RHEL 7 virtual machine without adjusting the default ram settings failed. Fix: Set the default ram allotment to 768 MB for RHEL 7 virtual machines. Result: Provisioning RHEL 7 virtual machines now works as expected.
Clone Of:
Environment:
Last Closed: 2014-01-20 09:23:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0042 normal SHIPPED_LIVE Red Hat Satellite server bug fix update 2014-01-20 14:22:18 UTC

Description Lukas Pramuk 2013-11-26 13:37:20 UTC
Description of problem:
Virtual Memory (in MB) default should be increased to 768MB when provisioning kvm guest using kickstartable tree of RHEL7. 
RHEL6 default is 512MB and causes anaconda to fail (OOM)

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. register VHost into SAT, enable Provisioning entitlement 
2. create a kickstart based on a RHEL7 kickstartable tree with virtualization type set to KVM Virtualized Guest 
3. provision kvm guest using defaults (i.e Virtual Memory se to 512MB)
4. anaconda fails during install - OOM

Actual results:
failed provisioning using the defaults (anaconda OOM)

Expected results:
successful provisioning

Additional info:
Virtual Disk Space default (3GB) is sufficient for RHEL7 - no need to change

Comment 1 Stephen Herr 2013-12-09 21:21:30 UTC
*** Bug 1039192 has been marked as a duplicate of this bug. ***

Comment 2 Stephen Herr 2013-12-09 21:33:48 UTC
The problem is that this is not a change we can make.

The 512 MB default is in a cobbler configuration. If we updated it to 768 MB or anything else and released a new cobbler package, then the updated config file would get saved as /etc/cobbler/settings.rpmsave and not take affect unless the customer manually updates the config file and restarts cobblerd.

If a manual intervention and modifying of config files is required, then perhaps the best solution is simply to publish a knowledgebase article telling people they must modify the default ram for RHEL 7 kickstart profiles to 768 MB or higher.

Comment 3 Stephen Herr 2013-12-10 21:53:48 UTC
Fix committed to Spacewalk master:
009fab04141c565843e871bc705604f6a15465d2

Comment 6 Stephen Herr 2013-12-18 14:57:02 UTC
We also need spacewalk commit: 4003937da4077c674d6b60b52a506da5728a37ef

Comment 14 errata-xmlrpc 2014-01-20 09:23:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0042.html


Note You need to log in before you can comment on or make changes to this bug.