Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 103464 - Problems with localisation
Summary: Problems with localisation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: switchdesk
Version: beta1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
: 73178 85415 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-31 11:52 UTC by Kjartan Maraas
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-04-07 15:34:34 UTC


Attachments (Terms of Use)
Norwegian translation of the meny entry (deleted)
2003-08-31 11:55 UTC, Kjartan Maraas
no flags Details | Diff
patch to fix localisation (deleted)
2003-08-31 13:29 UTC, Kjartan Maraas
no flags Details | Diff
Patch fixing the Qt frontend. (deleted)
2003-08-31 14:01 UTC, Miloslav Trmac
no flags Details | Diff
screendump (deleted)
2003-08-31 14:12 UTC, Kjartan Maraas
no flags Details

Description Kjartan Maraas 2003-08-31 11:52:09 UTC
Description of problem:

When running switchdesk with Norwegian locale I still get the english strings. I
think the problem could be in switchdesk/src/switchdesk-gnome.c where config.h
should be the very first include instead of being placed down with the intl.h
include.

Also attaching a norwegian translation for the .desktop file.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Kjartan Maraas 2003-08-31 11:54:26 UTC
Also, should the .desktop file be utf8 encoded?

Comment 2 Kjartan Maraas 2003-08-31 11:55:49 UTC
Created attachment 94094 [details]
Norwegian translation of the meny entry

Comment 3 Kjartan Maraas 2003-08-31 12:24:04 UTC
*** Bug 85415 has been marked as a duplicate of this bug. ***

Comment 4 Kjartan Maraas 2003-08-31 13:28:19 UTC
Attaching a tested patch for switchdesk-gnome.c - the KDE variant doesn't work
here and I don't know KDE's i18n framework well enough to look into it.

Comment 5 Kjartan Maraas 2003-08-31 13:29:15 UTC
Created attachment 94095 [details]
patch to fix localisation

Comment 6 Kjartan Maraas 2003-08-31 13:36:51 UTC
After looking at the strace output when running the KDE variant it seems as if
it's looking in the wrong place for the message catalog. switchdesk-kde is
looking in /usr/share/locale/no_NO.UTF-8/LC_MESSAGES when it's really in
/usr/share/locale/no/LC_MESSAGES



Comment 7 Miloslav Trmac 2003-08-31 14:01:08 UTC
Created attachment 94096 [details]
Patch fixing the Qt frontend.

Patch fixing the Qt frontend (not tested with USE_KDE2):
* switchdesk was looking for "messages.mo" instead of "switchdesk.mo"
* The translations were assumed to be in Latin-1

TODO: use intltool for .desktop translation, if someone cares enough.

Comment 8 Kjartan Maraas 2003-08-31 14:11:04 UTC
Attaching a screenshot that shows the text is overlapped with the logo.

Comment 9 Kjartan Maraas 2003-08-31 14:12:00 UTC
Created attachment 94097 [details]
screendump

Comment 10 Kjartan Maraas 2003-09-05 13:33:07 UTC
*** Bug 73178 has been marked as a duplicate of this bug. ***

Comment 11 Ngo Than 2004-02-03 21:27:03 UTC
it's fixed in 4.0.0, which is available in rawhide

Comment 12 Miloslav Trmac 2004-04-07 13:40:03 UTC
OK, please push it to elvis.redhat.com (including updated .po files)
so that it can be translated.

Thanks.

Comment 13 Ngo Than 2004-04-07 13:47:59 UTC
It's already on elvis a month ago! Could you please check it from CVS
again.

Comment 14 Miloslav Trmac 2004-04-07 14:12:38 UTC
Yes, the code is there, but the .po files are not updated.
The glade file has revisions dated 2004/02/15 and 2004/04/06,
but (grep -h POT-Creation-Date *|sort -u) shows the files
were updated last time on 2004/02/01, some of them even
2003/01/02.

The way it currently works (I don't like it that much either)
is that developers should manually run (make -C po update-po)
and push the results to elvis.


Comment 15 Ngo Than 2004-04-07 15:11:56 UTC
ok, i have done the po files update and already commited the changes
into CVS. Could you please check again. Thanks

Comment 16 Miloslav Trmac 2004-04-07 15:34:34 UTC
Looks fine, thanks a lot!


Note You need to log in before you can comment on or make changes to this bug.