Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1034322 - [ovirt-guest-agent] GNOME screen is not locked when console window is closed
Summary: [ovirt-guest-agent] GNOME screen is not locked when console window is closed
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.3.2
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-11-25 15:35 UTC by Jiri Belka
Modified: 2014-09-18 12:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-07 13:40:25 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Belka 2013-11-25 15:35:59 UTC
Description of problem:

I discovered that GNOME screen is not locked when console which is opened from User Portal, is closed. The issue appears on both RHEL 6.4 and RHEL 6.5.

-%-
...snip...
CredChannel::INFO::2013-11-25 15:32:03,563::CredServer::241::root::Credentials channel timed out.
Dummy-1::INFO::2013-11-25 15:32:03,563::CredServer::277::root::Credentials channel was closed.
Dummy-1::INFO::2013-11-25 15:32:09,497::OVirtAgentLogic::169::root::Received an external command: lock-screen...
Dummy-1::INFO::2013-11-25 15:32:09,553::OVirtAgentLogic::169::root::Received an external command: lock-screen...
Dummy-1::INFO::2013-11-25 15:32:09,588::OVirtAgentLogic::169::root::Received an external command: lock-screen...
Dummy-1::INFO::2013-11-25 15:32:09,624::OVirtAgentLogic::169::root::Received an external command: lock-screen...
Dummy-1::INFO::2013-11-25 15:32:09,660::OVirtAgentLogic::169::root::Received an external command: lock-screen...
Dummy-1::INFO::2013-11-25 15:32:09,695::OVirtAgentLogic::169::root::Received an external command: lock-screen...
Dummy-1::INFO::2013-11-25 15:32:09,732::OVirtAgentLogic::169::root::Received an external command: lock-screen...
Dummy-1::INFO::2013-11-25 15:34:03,479::OVirtAgentLogic::169::root::Received an external command: login...
Dummy-1::INFO::2013-11-25 15:34:03,480::CredServer::207::root::The following users are allowed to connect: [0]
Dummy-1::INFO::2013-11-25 15:34:03,480::CredServer::273::root::Opening credentials channel...
Dummy-1::INFO::2013-11-25 15:34:03,480::CredServer::132::root::Emitting user authenticated signal (949401).
CredChannel::INFO::2013-11-25 15:34:08,485::CredServer::241::root::Credentials channel timed out.
Dummy-1::INFO::2013-11-25 15:34:08,486::CredServer::277::root::Credentials channel was closed.
-%-

-%-
# ./LockActiveSession.py
ERROR:root:Error retrieving ScreenSaver interface (ignore if running on GNOME).
Traceback (most recent call last):
  File "./LockActiveSession.py", line 51, in GetScreenSaver
    'org.freedesktop.ScreenSaver', '/ScreenSaver'),
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 244, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 241, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 183, in activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.6/site-packages/dbus/bus.py", line 281, in start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.ScreenSaver was not provided by any .service files
-%-

Version-Release number of selected component (if applicable):
dbus-1.2.24-7.el6_3.x86_64
dbus-c++-0.5.0-0.10.20090203git13281b3.1.el6.x86_64
dbus-glib-0.86-6.el6_4.x86_64
dbus-libs-1.2.24-7.el6_3.x86_64
dbus-python-0.83.0-6.1.el6.x86_64
dbus-x11-1.2.24-7.el6_3.x86_64
rhevm-guest-agent-common-1.0.8-6.el6ev.noarch (is24.2)
rhevm-guest-agent-gdm-plugin-1.0.8-6.el6ev.x86_64
rhevm-guest-agent-pam-module-1.0.8-6.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. have sso working from User Portal (GA working)
2. open console, close console
3. reopen console

Actual results:
when console is reopened the screen is not locked

Expected results:
screen should be locked

Additional info:
screen should be locked because currently GA does not have screen unlock feature.

Comment 1 Vinzenz Feenstra [evilissimo] 2014-02-03 12:51:04 UTC
Tested on the latest RHEL-6.5 installed from ISO and this issue cannot be reproduced. Please try to reproduce this again

Comment 3 Jiri Belka 2014-02-07 13:23:27 UTC
I can't reproduce - rhevm-guest-agent-gdm-plugin-1.0.8-6.el6ev.x86_64.rpm.

Comment 4 Vinzenz Feenstra [evilissimo] 2014-02-07 13:40:25 UTC
Closing according c#3


Note You need to log in before you can comment on or make changes to this bug.