Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1033118 - "A new version is available; an upgrade option will appear once the Host is moved to maintenance mode." in General Tab
Summary: "A new version is available; an upgrade option will appear once the Host is m...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
: 1053049 (view as bug list)
Depends On: 829220
Blocks: 1034817 1034819 1055553 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-11-21 15:18 UTC by Chris Pelland
Modified: 2019-04-16 14:06 UTC (History)
25 users (show)

Fixed In Version: ovirt-node-3.0.1-14.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 1027702
: 1034817 1034819 (view as bug list)
Environment:
Last Closed: 2015-02-11 20:47:44 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Comment 8 Fabian Deutsch 2014-01-14 14:39:48 UTC
How to test this bug:

1. RHEV-M installed on machine (M)
2. Install latest 6.4 RHEV-H on machine (H)
3. Install RC RHEV-H wrapper-rpm on (M)
4. Upgrade (H) through (M)

Result.
Upgrade warning should not be shown

Comment 9 Martin Pavlik 2014-01-14 15:36:29 UTC
1) Installed fresh RHEV-H rhev-hypervisor6-6.4-20131016.0.1026335.el6_4 from PXE
2) added it to RHEV-M 3.3 (is32) into 3.2 Data Center / Cluster
3) installed rhev-hypervisor6-6.5-20140112.0.el6ev on RHEV-M
4) upgraded RHEV-H via RHEV-M
5) after upgrade the message: 
A new version is available; an upgrade option will appear once the Host is moved to maintenance mode.
appeared again

Comment 11 Chris Pelland 2014-01-15 22:01:49 UTC
*** Bug 1053049 has been marked as a duplicate of this bug. ***

Comment 12 Guohua Ouyang 2014-01-16 04:23:25 UTC
the bug is fixed on rhevh-6.5-20140115.0.el6ev:

1. all the suffix are el6ev now:
[root@rhevm-is-1 ~]# ls /usr/share/rhev-hypervisor/rhevh-6.5-20140115.0.el6ev.iso 
/usr/share/rhev-hypervisor/rhevh-6.5-20140115.0.el6ev.iso

[root@hp-dl388g7-01 /]# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140115.0.el6ev)

[root@hp-dl388g7-01 /]# cat /etc/system-release
Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140115.0.el6ev)

2. verified on rhevm-is 3.2 cluster:
2.1:
1) Installed fresh RHEV-H rhev-hypervisor6-6.4-20131016.0 from PXE
2) added it to RHEV-M 3.3 into 3.2 Data Center / Cluster
3) installed rhev-hypervisor6-6.5-20140112.0.el6ev on RHEV-M
4) upgraded RHEV-H via RHEV-M
5) after upgrade the message: 
A new version is available; an upgrade option will appear once the Host is moved to maintenance mode.
6) installed rhev-hypervisor6-6.5-20140115.0.el6ev.noarch.rpm on RHEV-M
7) upgrade RHEV-H to 6.5-20140115.0.el6ev via RHEV-M
8) after upgrade, no messsage like "A new version is available"

2.2:
1) Installed fresh RHEV-H rhev-hypervisor6-6.4-20131016.0 from PXE
2) added it to RHEV-M 3.3 into 3.2 Data Center / Cluster
3) installed rhev-hypervisor6-6.5-20140115.0.el6ev on RHEV-M
4) upgraded RHEV-H via RHEV-M
5) after upgrade, no messsage like "A new version is available"

Comment 16 Evgheni Dereveanchin 2014-01-29 09:39:33 UTC
I wanted to note again that we need to include the check in test coverage for every release since customers are unhappy about the fact that the issue with suffixes not matching happens so often in RHEV-H releases.

Comment 18 Yaning Wang 2014-12-17 08:27:29 UTC
verified on rhevm

Test steps:

1) Installed fresh RHEV-H RHEVH-6.5-1017.0.el6ev from PXE
2) added it to RHEV-M 3.5.0-0.25.el6ev
3) installed RHEVH 6.6-20141212.0.el6ev on RHEV-M
4) upgraded RHEV-H via RHEV-M
5) after upgrade, no messsage like "A new version is available" appear

Comment 20 errata-xmlrpc 2015-02-11 20:47:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.