Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1032689 - [ovirt-engine-iso-uploader] engine-ca -> cert-file option switch, support old option name
Summary: [ovirt-engine-iso-uploader] engine-ca -> cert-file option switch, support old...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: 1055496 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-11-20 15:20 UTC by Jiri Belka
Modified: 2014-09-18 12:24 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Previously, the parameter for specifcing the path and file name of the engine certificate to be used by the engine-iso-uploader command was '--engine-ca'. Now, this argument has been changed to '--cert-file'. This update provides backwards compatibility to update the old parameter to the new parameter in environments upgraded from Red Hat Enterprise Virtualization 3.1.
Clone Of:
: 1046303 1046309 1055496 (view as bug list)
Environment:
Last Closed: 2014-06-09 14:16:01 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0666 normal SHIPPED_LIVE rhevm-iso-uploader bug fix and enhancement update 2014-06-09 18:14:39 UTC
oVirt gerrit 22698 None None None Never

Description Jiri Belka 2013-11-20 15:20:51 UTC
Description of problem:
between 3.1 and 3.2 there was renaming of option which defines path to certificate of engine.

--engine-ca -> --cert-file

Annoying renaming, one has to define new optiname name on cmd line.

-%-
# rhevm-iso-uploader --engine-ca=rhevm.cer -v list                                                                                            
DEBUG: API Vendor(Red Hat)      API Version(3.3.0)
DEBUG: Found a DC named(Default)
ISO Storage Domain Name   | Datacenter                | ISO Domain Status
str01-iso-shared          | Default                   | active
-%-

After upgrade...

-%-
# rhevm-iso-uploader --engine-ca=rhevm.cer -v list                                                                                            
Usage: rhevm-iso-uploader [options] list 
       rhevm-iso-uploader [options] upload FILE [FILE]...[FILE]

rhevm-iso-uploader: error: no such option: --engine-ca
# rhevm-iso-uploader --cert-file=rhevm.cer -v list                                                                                            
DEBUG: API Vendor(Red Hat)      API Version(3.3.0)
DEBUG: Found a DC named(Default)
ISO Storage Domain Name   | Datacenter                | ISO Domain Status
str01-iso-shared          | Default                   | active
-%-



Version-Release number of selected component (if applicable):
is24

How reproducible:
100%

Steps to Reproduce:
1. have 3.1 app
2. upgrade to latest 3.2 or 3.3
3.

Actual results:
--engine-ca option is invalid

Expected results:
support old option name

Additional info:
what a benefit of renaming :)

Comment 2 Sandro Bonazzola 2013-12-24 10:37:26 UTC
(In reply to Jiri Belka from comment #0)

> Actual results:
> --engine-ca option is invalid
> 
> Expected results:
> support old option name
> 
> Additional info:
> what a benefit of renaming :)

Renaming was introduced for fixing bug #894688.
We can't keep --engine-ca on command line due to that bug but we should avoid to exit with error if the engine_ca key is used in the configuration file.

Comment 3 Sandro Bonazzola 2013-12-24 14:18:25 UTC
merged on upstream mater branch for 3.4.0 rebase.

Comment 5 Jiri Belka 2014-01-28 15:19:07 UTC
ok, ovirt-iso-uploader-3.4.0-0.1.beta1.el6.noarch

$ egrep "engine-ca|rhevm" /tmp/etc/ovirt-engine/isouploader.conf 
rhevm=10.34.63.78:443
engine-ca=/home/jbelka/ca.crt
[jbelka@foobar ~]$ rpm -q ovirt-iso-uploader

$ sudo engine-iso-uploader --conf-file=/tmp/etc/ovirt-engine/isouploader.conf -v list
DEBUG: API Vendor(ovirt.org)    API Version(3.4.0)
DEBUG: Found a DC named(Default)
ISO Storage Domain Name   | Datacenter                | ISO Domain Status
ISO                       | Default                   | active

Comment 7 errata-xmlrpc 2014-06-09 14:16:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0666.html


Note You need to log in before you can comment on or make changes to this bug.