Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1032682 - Refactor authentication framework in engine
Summary: Refactor authentication framework in engine
Keywords:
Status: CLOSED DUPLICATE of bug 1057368
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Yair Zaslavsky
QA Contact: Ondra Machacek
URL:
Whiteboard: infra
Depends On:
Blocks: oVirt-AAA-rewrite
TreeView+ depends on / blocked
 
Reported: 2013-11-20 15:09 UTC by Barak
Modified: 2015-03-05 00:19 UTC (History)
8 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1057368 (view as bug list)
Environment:
Last Closed: 2014-03-31 12:27:57 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Barak 2013-11-20 15:09:13 UTC
The current Authentication authorization code in the engine is limiting,
The purpose of this work is to:
- separate authentication and authorization
- enable pluggable authentication and authorization providers

This will enable adding different authentication providers such as keystone and others

Comment 2 Barak 2014-01-15 22:25:23 UTC
15 patches were merged with the refactoring work,

the tip is http://gerrit.ovirt.org/#/c/21029/

Comment 3 Barak 2014-01-22 13:49:13 UTC
The part that was merged is the move to the new auth & domain provider interfaces, and reuse of the old code (providers) to achieve same functionality.

Comment 4 Sandro Bonazzola 2014-02-07 11:20:17 UTC
Fixes should be in ovirt-3.4.0-beta2. Assignee please check.

Comment 5 Yair Zaslavsky 2014-02-10 08:14:46 UTC
(In reply to Sandro Bonazzola from comment #4)
> Fixes should be in ovirt-3.4.0-beta2. Assignee please check.

I followed your instructions , and fetched the code of beta2.
It is in. thanks.

Comment 6 Ondra Machacek 2014-03-18 11:10:53 UTC
Verified.

Run regression tests for IPA/OpenLDAP/389ds and AD.

Comment 7 Sandro Bonazzola 2014-03-31 12:27:57 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Comment 8 Alon Bar-Lev 2014-11-04 09:13:16 UTC

*** This bug has been marked as a duplicate of bug 1057368 ***


Note You need to log in before you can comment on or make changes to this bug.