Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1031965 - unclear error message for x-data-plane=on specified for libiscsi storage disk
Summary: unclear error message for x-data-plane=on specified for libiscsi storage disk
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Stefan Hajnoczi
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 1064761 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-19 09:12 UTC by Sibiao Luo
Modified: 2014-02-13 23:34 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-06 14:09:11 UTC


Attachments (Terms of Use)

Description Sibiao Luo 2013-11-19 09:12:16 UTC
Description of problem:
fail to boot guest with x-data-plane=on specified for libiscsi storage disk, qemu will quit with warning message prompt 'drive is incompatible with x-data-plane, use format=raw,cache=none,aio=native'. We can fix it to work well or disable it with friendly warning message if not support it.
Also tried:
1.it can boot up guest with x-data-plane=off specified for libiscsi storage disk.
2.it can boot up guest with x-data-plane=on specified for local file storage disk.

Version-Release number of selected component (if applicable):
host info:
3.10.0-50.el7.x86_64
qemu-kvm-rhev-1.5.3-19.el7.x86_64
seabios-1.7.2.2-4.el7.x86_64
guest info:
rhel6.5 32bit/64bit
2.6.32-425.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot guest with x-data-plane=on specified for libiscsi storage disk.
e.g:/usr/libexec/qemu-kvm -M q35 -S -cpu SandyBridge -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -no-kvm-pit-reinjection...-drive file=iscsi://10.66.6.82:3260/iqn.2013-11.com.example:storage.disk1.juli.xyz/5,if=none,id=drive-data-disk,format=raw,cache=none,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,bus=pcie.0,addr=0x7,scsi=off,x-data-plane=on,config-wce=off,drive=drive-data-disk,id=data-disk -iscsi id=iqn1
2.boot guest with x-data-plane=off specified for libiscsi storage disk.
e.g:/usr/libexec/qemu-kvm -M q35 -S -cpu SandyBridge -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -no-kvm-pit-reinjection...-drive file=iscsi://10.66.6.82:3260/iqn.2013-11.com.example:storage.disk1.juli.xyz/5,if=none,id=drive-data-disk,format=raw,cache=none,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,bus=pcie.0,addr=0x7,scsi=off,x-data-plane=off,config-wce=off,drive=drive-data-disk,id=data-disk -iscsi id=iqn1
3.boot up guest with x-data-plane=on/off specified for local file storage disk.
e.g:/usr/libexec/qemu-kvm -M q35 -S -cpu SandyBridge -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -no-kvm-pit-reinjection...-drive file=/home/my-data-disk.raw,if=none,id=drive-data-disk,format=raw,cache=none,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,bus=pcie.0,addr=0x7,scsi=off,x-data-plane=on,config-wce=off,drive=drive-data-disk,id=data-disk

Actual results:
after step 1, qemu will quit and fail to boot up.
QEMU 1.5.3 monitor - type 'help' for more information
(qemu) qemu-kvm: -device virtio-blk-pci,bus=pcie.0,addr=0x7,scsi=off,x-data-plane=on,config-wce=off,drive=drive-data-disk,id=data-disk: drive is incompatible with x-data-plane, use format=raw,cache=none,aio=native
qemu-kvm: -device virtio-blk-pci,bus=pcie.0,addr=0x7,scsi=off,x-data-plane=on,config-wce=off,drive=drive-data-disk,id=data-disk: Device initialization failed.
qemu-kvm: -device virtio-blk-pci,bus=pcie.0,addr=0x7,scsi=off,x-data-plane=on,config-wce=off,drive=drive-data-disk,id=data-disk: Device initialization failed.
qemu-kvm: -device virtio-blk-pci,bus=pcie.0,addr=0x7,scsi=off,x-data-plane=on,config-wce=off,drive=drive-data-disk,id=data-disk: Device 'virtio-blk-pci' could not be initialized
after step 2, it can boot up successfully.
after step 3, it can boot up successfully.

Expected results:
We can fix it to work well with x-data-plane=on specified for libiscsi storage disk or disable it with friendly warning message if not support it.

Additional info:

Comment 1 Sibiao Luo 2013-11-19 09:13:49 UTC
My qemu-kvm command line:
# /usr/libexec/qemu-kvm -M q35 -S -cpu SandyBridge -enable-kvm -m 2048 -smp 2,sockets=2,cores=1,threads=1 -no-kvm-pit-reinjection -usb -device usb-tablet,id=input0 -name sluo -uuid 990ea161-6b67-47b2-b803-19fb01d30d10 -rtc base=localtime,clock=host,driftfix=slew -device virtio-serial-pci,id=virtio-serial0,max_ports=16,vectors=0,bus=pcie.0,addr=0x3 -chardev socket,id=channel1,path=/tmp/helloworld1,server,nowait -device virtserialport,chardev=channel1,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port1 -chardev socket,id=channel2,path=/tmp/helloworld2,server,nowait -device virtserialport,chardev=channel2,name=com.redhat.rhevm.vdsm,bus=virtio-serial0.0,id=port2 -drive file=/home/RHEL6.5-20131019.1_Server_x86_64.qcow2bk,if=none,id=drive-virtio-disk,format=qcow2,cache=none,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,vectors=0,bus=pcie.0,addr=0x4,scsi=off,drive=drive-virtio-disk,id=virtio-disk,bootindex=1 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=virtio-net-pci0,mac=00:01:02:03:04:05,bus=pcie.0,addr=0x5 -device virtio-balloon-pci,id=ballooning,bus=pcie.0,addr=0x6 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -drive file=iscsi://10.66.6.82:3260/iqn.2013-11.com.example:storage.disk1.juli.xyz/5,if=none,id=drive-data-disk,format=raw,cache=none,aio=native,werror=stop,rerror=stop -device virtio-blk-pci,bus=pcie.0,addr=0x7,scsi=off,x-data-plane=on,config-wce=off,drive=drive-data-disk,id=data-disk -iscsi id=iqn1 -k en-us -boot menu=on -qmp tcp:0:4444,server,nowait -serial unix:/tmp/ttyS0,server,nowait -vnc :1 -spice disable-ticketing,port=5931 -monitor stdio

Comment 2 Paolo Bonzini 2013-11-19 09:19:43 UTC
Dataplane only supports local storage right now.

Comment 4 Paolo Bonzini 2014-02-13 23:34:31 UTC
*** Bug 1064761 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.