Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1031624 - [web admin portal] - Basic VM's attribute are enabled in up state, but can be changeable only when its down
Summary: [web admin portal] - Basic VM's attribute are enabled in up state, but can be...
Keywords:
Status: CLOSED DUPLICATE of bug 922377
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Tomas Jelinek
QA Contact: Pavel Stehlik
URL:
Whiteboard: virt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-18 12:08 UTC by Barak Dagan
Modified: 2014-07-13 23:20 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-31 12:14:15 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Barak Dagan 2013-11-18 12:08:49 UTC
Description of problem:
Cluster, OS and optimized for attribute (located in the gray BG part), can be adjusted when the VM is down, but are enabled always. Changing the values when VM is not down (up, suspend for example) results popup:
"
Error while executing action:

[vm name]:

    Failed updating the properties of the VM. VM should be in status Down in order to change the sound device."

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. edit vm in up state
2. change os / optimized for value
3.

Actual results:


Expected results:
that these option would be grayed out as they are for vms from pools

Additional info:

Comment 1 Michal Skrivanek 2014-01-31 12:14:15 UTC
bug 922377 will take care of this

*** This bug has been marked as a duplicate of bug 922377 ***


Note You need to log in before you can comment on or make changes to this bug.