Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1031386 - [engine-webadmin] inappropriate message when trying to perform an operation on a locked disk
Summary: [engine-webadmin] inappropriate message when trying to perform an operation o...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Sergey Gotliv
QA Contact: Leonid Natapov
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-11-17 15:35 UTC by Elad
Modified: 2016-02-10 16:38 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
engine.log and screenshot (deleted)
2013-11-17 15:35 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 21800 None None None Never

Description Elad 2013-11-17 15:35:19 UTC
Created attachment 825162 [details]
engine.log and screenshot

Description of problem:
I tried to deactivate (hotunplug) a disk while it was in locked state (due to previous deactivation). Engine blocked me from doing it with a CanDoAction but on UI I got this message:

"Cannot hot plug Virtual Machine Disk: The following disks are locked: ${diskAliases}. Please try again in a few minutes."

Version-Release number of selected component (if applicable):
is23
rhevm-3.3.0-0.33.beta1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deactivate (hotunplug) a disk when the disk is in locked state


Actual results:
On engine.log, I'm getting:

2013-11-17 17:26:11,922 WARN  [org.ovirt.engine.core.bll.HotPlugDiskToVmCommand] (ajp-/127.0.0.1:8702-10) [47da8965] CanDoAction of action HotPlugDiskToVm failed. Reasons:VAR__ACTION__HOT_PLUG,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_DISKS_LOCKED

The message on UI is presented with ${diskAliases} instead of the disk alias itself.

Expected results:
We should get the disk alias itself in the error message on UI

Additional info: engine.log and screenshot

Comment 1 Sandro Bonazzola 2014-01-14 08:44:26 UTC
ovirt 3.4.0 alpha has been released

Comment 2 Leonid Natapov 2014-02-16 12:15:18 UTC
3.4.0-0.7.beta2.el6. fixed. deactivate button greyed out while disk is locked.

Comment 3 Itamar Heim 2014-06-12 14:06:52 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.