Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1029973 - [RHEVM] [webadmin] long vNIC name breaks layout of Edit Virtual Machine dialog
Summary: [RHEVM] [webadmin] long vNIC name breaks layout of Edit Virtual Machine dialog
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: 3.5.0
Assignee: Alona Kaplan
QA Contact: Michael Burman
URL:
Whiteboard: network
Depends On: 1096662
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-11-13 15:58 UTC by Martin Pavlik
Modified: 2016-02-10 19:56 UTC (History)
11 users (show)

Fixed In Version: av3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:09:37 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)
screenshot 1 (deleted)
2013-11-13 15:58 UTC, Martin Pavlik
no flags Details
png (deleted)
2014-03-16 14:52 UTC, Meni Yakove
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 25005 None None None Never
oVirt gerrit 25432 None None None Never
oVirt gerrit 29126 master MERGED webadmin: Limiting vnic name label width on vm dialog Never

Description Martin Pavlik 2013-11-13 15:58:01 UTC
Created attachment 823506 [details]
screenshot 1

Description of problem:
if VM has a vNIC with long name (e.g. 012345678901234567890123456789012345678901234567890123456789)

it breaks layout of edit VM dialog (see screenshot)

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.32.beta1.el6ev 

How reproducible:
100%

Steps to Reproduce:
1. create new VM
2. add vNIC with long name e.g. 012345678901234567890123456789012345678901234567890123456789
3. Virtual Machines -> your VM -> Edit

Actual results:
Edit virtual machines dialog has broken layout

Expected results:
Long names correctly displayed

Additional info:
this will also appear on new VM dialog if blank template has vNIC with long name in it

Comment 1 Lior Vernia 2014-03-05 15:43:41 UTC
Note that the room for the vNIC name was increased within the realm of the reasonable, but this can still be messed up if the name is long enough. This would be hard to solve for any length, as I don't think we limit the length of a vNIC name anywhere; if we start limiting it now, this will cause trouble to existing users with long vNIC names.

Comment 2 Meni Yakove 2014-03-16 14:52:36 UTC
Created attachment 875145 [details]
png

Comment 3 Meni Yakove 2014-03-16 14:53:11 UTC
Problem still exists.
See attach image

Comment 4 Lior Vernia 2014-03-16 18:00:41 UTC
See my previous comment.

Comment 5 Lior Vernia 2014-03-17 12:03:01 UTC
To myakove's suggestion, probably possible to solve with three dots and a tooltip or something of the sort.

Comment 8 Eyal Edri 2015-02-17 17:09:37 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.