Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1029812 - vdsm-tool configure outputs misleading error messages although it ends successfully
Summary: vdsm-tool configure outputs misleading error messages although it ends succes...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
: 3.4.0
Assignee: Yaniv Bronhaim
QA Contact: Petr Beňas
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-11-13 09:41 UTC by Vered Volansky
Modified: 2016-05-05 04:38 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.4.0-beta2
Doc Type: Bug Fix
Doc Text:
This update enhances the output produced by the vdsm-tool to provide more information to users on encountering errors.
Clone Of:
Environment:
Last Closed: 2014-06-09 13:26:34 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0504 normal SHIPPED_LIVE vdsm 3.4.0 bug fix and enhancement update 2014-06-09 17:21:35 UTC
oVirt gerrit 23253 None None None Never
oVirt gerrit 23440 None None None Never

Description Vered Volansky 2013-11-13 09:41:48 UTC
Description of problem:
When running vdsm-tool configure we get the output as follows:
--------------------------------------------------------------
SUCCESS: ssl configured to true. No conflicts
libvirt is not configured for vdsm yet
sanlock service is already configured
service-status: ServiceOperationError: _serviceStatus failed
Super VDSM daemon is not running

service-status: ServiceOperationError: _serviceStatus failed
VDS daemon is not running

service-status: ServiceOperationError: _serviceStatus failed
libvirtd is stopped

Reconfiguration of libvirt is done

Version-Release number of selected component (if applicable):
--------------------------------------------------------------

How reproducible:


Steps to Reproduce:
1.service libvirtd stop
2.service supervdsmd stop
3.vdsm-tool configure

Actual results:
The above output, as well as successful libvirt configuration.

Expected results:
The service-status: ServiceOperationError: _serviceStatus failed messages give the impression something went wrong, although the configuration was successful.
Assuming the process is fine, they should either be swallowed or marked as notes. Another solution if thought of will also be acceptable.

Additional info:
Ran on a rhel machine.

Comment 1 Yaniv Bronhaim 2013-11-13 11:44:35 UTC
Yes, it looks kinda funny imo. I'll think what we can do there..
Thanks.

Comment 2 Petr Beňas 2014-02-19 11:39:58 UTC
Verified in vdsm-4.14.1-3.el6.x86_64.

[root@slot-7 ~]# vdsm-tool configure

Checking configuration status...

SUCCESS: ssl configured to true. No conflicts
libvirt is not configured for vdsm yet
sanlock service is already configured
Traceback (most recent call last):
  File "/usr/bin/vdsm-tool", line 145, in <module>
    sys.exit(main())
  File "/usr/bin/vdsm-tool", line 142, in main
    return tool_command[cmd]["command"](*args[1:])
  File "/usr/lib64/python2.6/site-packages/vdsm/tool/configurator.py", line 213, in configure
    "--force flag.\n" % s
RuntimeError: 

Cannot configure while service 'vdsmd' is running.
 Stop the service manually or use the --force flag.

[root@slot-7 ~]# service vdsmd stop
Shutting down vdsm daemon: 
vdsm watchdog stop                                         [  OK  ]
vdsm: Running run_final_hooks                              [  OK  ]
vdsm stop                                                  [  OK  ]
[root@slot-7 ~]# vdsm-tool configure

Checking configuration status...

SUCCESS: ssl configured to true. No conflicts
libvirt is not configured for vdsm yet
sanlock service is already configured

Running configure...
Reconfiguration of libvirt is done.

Done configuring modules to VDSM.
[root@slot-7 ~]# vdsm-tool configure

Checking configuration status...

SUCCESS: ssl configured to true. No conflicts
libvirt is already configured for vdsm
sanlock service is already configured

Running configure...

Done configuring modules to VDSM.

Comment 5 Vered Volansky 2014-05-14 04:17:41 UTC
Doc-text is actually wrong. The update removed misleading error messages that shouldn't have gotten to the user the way they did. It does not provide *more* inforamtion to the user. Bronheim, do you agree?

Comment 6 Yaniv Bronhaim 2014-05-18 13:41:52 UTC
no, the output was correct but hard to understand. this is only enhancement in stdout prints, as described in the doc-text.

Comment 7 errata-xmlrpc 2014-06-09 13:26:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0504.html


Note You need to log in before you can comment on or make changes to this bug.