Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1029801 - [RFE] [engine-image-uploader] recursive upload
Summary: [RFE] [engine-image-uploader] recursive upload
Keywords:
Status: CLOSED DUPLICATE of bug 716511
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-iso-uploader
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-11-13 09:09 UTC by Jiri Belka
Modified: 2014-02-05 05:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Allow to upload multiple images by recursively exploring the specified directory. Reason: Result (if any):
Clone Of:
Environment:
Last Closed: 2014-01-23 11:10:30 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Jiri Belka 2013-11-13 09:09:55 UTC
Description of problem:

See https://bugzilla.redhat.com/show_bug.cgi?id=1002320#c7

>> Ok, then, is17.
>> 
>> But it would be nice to have recursive upload. I can imagine it would be
>> useful to upload VMs from other data domain etc...
>
> Please open a RFE about it. We can think about adding that support in a future
> release.

Version-Release number of selected component (if applicable):
is22

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
engine-image-uploader could not do recursive uploads from storage

Expected results:
do recursive uploads

Additional info:
benefits:
* easy to "restore" VMs either from a different storage domain or from your storage domain if you lost DB and your DB backup is too old and does not know about newly created/used VMs

it would be also nice if engine-image-uploader could "scan" local storage. example:
* multiple VMs on local storage with 'internal layout' but I do not want to upload all of them. and I'm lazy to parse meta files to discover which uuid-based files refers to which VM. it would be nice if engine-image-upload could "scan" this and tell me the names or some other info, so i could upload only specific VM(s) without telling engine-image-upload specific path. thus, make it human friendly :)

Comment 2 Itamar Heim 2014-01-23 11:10:30 UTC
I'm closing this as our approach to fixing this is via:
RegisterDisk (3.2) and future work on import existing data domain / report orphan disks/vms on existing data domain (for example, bug 716511)

*** This bug has been marked as a duplicate of bug 716511 ***


Note You need to log in before you can comment on or make changes to this bug.