Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 102917 - agpgart and fglrx kernel modules fail to load. X server won't load. Dual monitor system ATI Fire GL 8800
Summary: agpgart and fglrx kernel modules fail to load. X server won't load. Dual mon...
Keywords:
Status: CLOSED DUPLICATE of bug 78616
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-22 17:11 UTC by Mike Eldredge
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:12 UTC


Attachments (Terms of Use)
X server log file (deleted)
2003-08-22 17:15 UTC, Mike Eldredge
no flags Details

Description Mike Eldredge 2003-08-22 17:11:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0; T312461)

Description of problem:
After installing the new kernel with up2date, I rebooted the machine.  The X 
server failed to start, and gave me the error messages about agpgart and fglrx 
modules failing to load.

If I go back to the previous kernel on boot (using grub), which is kernel 
2.4.20-19.9, everything works OK.

Under the new kernel, I can get the x server working with the default 
configuration tool which automatically probes my hardware.  The problem is, it 
doesn't detect that I have two monitors.  I end up with the second monitor 
looking like a clone of the first one, rather than having the two act as one 
big screen.

I tried rebuilding the XF86Config-4 file using the fglrxconfig tool that comes 
with the ATI Fire GL 8800 driver, but when I re-boot, I get the same error. 
(agpgart and fglrx modules fail to load)


Version-Release number of selected component (if applicable):
kernel-2.4.20-20.9

How reproducible:
Always

Steps to Reproduce:
1. upgrade to the 2.4.20-20.9 kernel from 2.4.20-19.9 using up2date
2. reboot
    

Actual Results:  The X server fails to load with an error message that agpgart 
and fglrx kernel modules fail to load

Expected Results:  The X server should have started normally

Additional info:

Hardware:
HP Workstation 5000
ATI Fire GL 8800
two Sony Trinitron Multiscan 20sfII monitors

Comment 1 Mike Eldredge 2003-08-22 17:15:01 UTC
Created attachment 93864 [details]
X server log file

Comment 2 Arjan van de Ven 2003-08-22 17:38:43 UTC

*** This bug has been marked as a duplicate of 78616 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:58:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.