Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1029066 - 503 Service Temporarily Unavailable: call channel.software.listPackagesWithoutChannel - synced packages from repository
Summary: 503 Service Temporarily Unavailable: call channel.software.listPackagesWithou...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomas Lestach
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2013-11-11 15:26 UTC by Pavel Studeník
Modified: 2014-01-20 16:42 UTC (History)
5 users (show)

Fixed In Version: spacewalk-java-2.0.2-56
Doc Type: Bug Fix
Doc Text:
Consequence: channel.software.listPackagesWithoutChannel API call may timeout when using Red Hat Satellite 5.6 with postgresql backend. Result: The appropriate query was enhanced, so channel.software.listPackagesWithoutChannel API call shall not timeout
Clone Of:
Environment:
Last Closed: 2014-01-20 09:22:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0042 normal SHIPPED_LIVE Red Hat Satellite server bug fix update 2014-01-20 14:22:18 UTC

Description Pavel Studeník 2013-11-11 15:26:02 UTC
Description of problem:
When I call API method "client.channel.software.listPackagesWithoutChannel(key)",
I get 503 http error. But I have the problem only on server, which was synced some channels and repositories:

I add new channels step by step and test call api - API works fine.

* synced channesl:
rhel-i386-server-5,Red Hat Enterprise Linux (v. 5 for 32-bit x86),12107
rhel-x86_64-server-5,Red Hat Enterprise Linux (v. 5 for 64-bit x86_64),15661
rhel-x86_64-server-6,Red Hat Enterprise Linux Server (v. 6 for 64-bit x86_64),11114
rhel-x86_64-server-vt-5,RHEL Virtualization (v. 5 for 64-bit x86_64),550
rhn-tools-rhel-i386-server-5,Red Hat Network Tools for RHEL Server (v.5 32-bit x86),555
rhn-tools-rhel-x86_64-server-5,Red Hat Network Tools for RHEL Server (v.5 64-bit x86_64),555
rhn-tools-rhel-x86_64-server-6,RHN Tools for RHEL (v. 6 for 64-bit x86_64),120

But When I add repository (rhel 7) and sync it. I got error 503. Same method is in WebUI (for showing packages which aren't in a channel), but webUI works quickly and without problem.

I found only this message in logs.

==> /var/log/tomcat6/catalina.out <==
Nov 5, 2013 8:51:15 AM org.apache.jk.common.ChannelSocket
processConnection WARNING: processCallbacks status 2

Version-Release number of selected component (if applicable):
spacewalk-java-postgresql-2.0.2-46.el6sat.noarch

How reproducible:
sometimes

Steps to Reproduce:
1. sync some big channels
2. create custom big channels and sync it with repository
3. call api: client.channel.software.listPackagesWithoutChannel(key)

Actual results:
Traceback (most recent call last):
  File "/mnt/tests/CoreOS/RHN-Satellite/Helper/manage-channel.py", line 371, in <module>
    delete_free_package(client, key, packageids)
  File "/mnt/tests/CoreOS/RHN-Satellite/Helper/manage-channel.py", line 273, in delete_free_package
    freeids = packages_without_channel(client, key)
  File "/mnt/tests/CoreOS/RHN-Satellite/Helper/manage-channel.py", line 249, in packages_without_channel
    packages = client.channel.software.listPackagesWithoutChannel(key)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1199, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1489, in __request
    verbose=self.__verbose
  File "/usr/lib64/python2.6/xmlrpclib.py", line 1243, in request
    headers
xmlrpclib.ProtocolError: <ProtocolError for dell-per805-01.rhts.eng.bos.redhat.com/rpc/api: 503 Service Temporarily Unavailable>

Expected results:
Result without traceback

Comment 1 Tomas Lestach 2013-11-12 15:48:02 UTC
enhancing the query for PG ...

spacewalk.git: 3934615463211e0f56660dd0029263b304c3c2bb

Comment 5 errata-xmlrpc 2014-01-20 09:22:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0042.html


Note You need to log in before you can comment on or make changes to this bug.