Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1028381 - [ovirt-guest-agent] `service ovirt-guest-agent start` prints 'Starting ovirt-guest-agent:' even the agent is already started
Summary: [ovirt-guest-agent] `service ovirt-guest-agent start` prints 'Starting ovirt-...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Jiri Belka
URL:
Whiteboard: virt
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-11-08 10:34 UTC by Jiri Belka
Modified: 2015-02-17 08:28 UTC (History)
5 users (show)

Fixed In Version: vt2.1
Doc Type: Bug Fix
Doc Text:
Previously, when starting the rhevm-guest-agent service when it was already running, reported that it was started. When it actually did not do anything. This can be confusing to users in some cases. This issues has been now resolved and it no longer reports as being started, but is reporting nothing as if the start of the service would have not done anything.
Clone Of:
Environment:
Last Closed: 2015-02-17 08:28:27 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28319 master MERGED No output when guest agent already running or stopped on RHEL5/6 Never

Description Jiri Belka 2013-11-08 10:34:28 UTC
Description of problem:
Nitpicking... But consistency.

# service sshd status
openssh-daemon (pid  1813) is running...
# service sshd status ; echo $?
openssh-daemon (pid  1813) is running...
0
# service sshd start ; echo $?
0
# service ovirt-guest-agent status ; echo $?
ovirt-guest-agent (pid  28458) is running...
0
# service ovirt-guest-agent start ; echo $?
Starting ovirt-guest-agent: 
0

Version-Release number of selected component (if applicable):
is21

How reproducible:
100%

Steps to Reproduce:
1. have ovirt-guest-agent running
2. service ovirt-guest-agent start
3.

Actual results:
confusing output - Starting ovirt-guest-agent:

Expected results:
no output

Additional info:
it confused me, i forgot if GA is running so i tried to start it and this output confused me because there is no '[OK]'. so was it started with my command or what...?

Comment 1 Jiri Belka 2013-11-08 10:40:37 UTC
Same on RHEL6 and RHEL5. Although RC scripts on RHEL are mess, still most of them do not print output in this context (blame auditd, cgconfig...).

Comment 3 Jiri Belka 2014-09-04 12:22:35 UTC
ok,

- el6:

[root@jb-onqa ~]# service ovirt-guest-agent start ; echo $?
Starting ovirt-guest-agent:                                [  OK  ]
0
[root@jb-onqa ~]# service ovirt-guest-agent status ; echo $?
ovirt-guest-agent (pid  28753) is running...
0
[root@jb-onqa ~]# service ovirt-guest-agent start ; echo $?
0

- el5:

[root@localhost ~]# service ovirt-guest-agent start ; echo $?
Starting ovirt-guest-agent:                                [  OK  ]
0
[root@localhost ~]# service ovirt-guest-agent status ; echo $?
ovirt-guest-agent (pid  2470) is running...
0
[root@localhost ~]# service ovirt-guest-agent start ; echo $?
0

Comment 4 Omer Frenkel 2015-02-17 08:28:27 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.