Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1028006 - [ovirt-guest-agent] rhevm-guest-agent on RHEL5 is not reported in appsList because pattern is RHEL6 specific
Summary: [ovirt-guest-agent] rhevm-guest-agent on RHEL5 is not reported in appsList be...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Jiri Belka
URL:
Whiteboard: virt
Depends On:
Blocks: 1069221 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-11-07 13:50 UTC by Jiri Belka
Modified: 2014-09-18 12:24 UTC (History)
8 users (show)

Fixed In Version: rhevm-guest-agent-1.0.8-9.el5
Doc Type: Bug Fix
Doc Text:
Previously, rhevm-guest-agent on RHEL5 was not reported in appsList, because the pattern was RHEL6 specific. Now, the pattern has been corrected, and rhevm-guest-agent is reported in appsList on RHEL5.
Clone Of:
: 1069221 (view as bug list)
Environment:
Last Closed: 2014-06-09 13:43:38 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Proposed fix for the guest agent fix (deleted)
2013-12-09 11:59 UTC, Vinzenz Feenstra [evilissimo]
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0654 normal SHIPPED_LIVE ovirt-guest-agent bug fix and enhancement update 2014-06-09 17:42:33 UTC

Description Jiri Belka 2013-11-07 13:50:37 UTC
Description of problem:
rhevm-guest-agent on RHEL5 is not reported in appsList because pattern is RHEL6 specific.

silly issue...

# grep ^appl /etc/ovirt-guest-agent.conf ; rpm -qa | grep rhevm-guest ; cat /etc/redhat-release 
applications_list = kernel rhevm-guest-agent-common xorg-x11-drv-qxl linux-image xserver-xorg-video-qxl
rhevm-guest-agent-1.0.8-5.el5ev
Red Hat Enterprise Linux Client release 5.10 (Tikanga)

# vdsClient -s 0 getVmStats c3f32ef3-2d0b-4f9d-9874-c054b976a8a0 | grep appsList
        appsList = ['kernel-2.6.18-371.1.2.el5', 'kernel-2.6.18-371.el5']


Version-Release number of selected component (if applicable):
rhevm-guest-agent-1.0.8-5.el5ev

How reproducible:
100%

Steps to Reproduce:
1. install agent
2. check if reported
3.

Actual results:
not reported

Expected results:
reported :)

Additional info:
rhel5 opposes novelties!

Comment 1 Vinzenz Feenstra [evilissimo] 2013-12-09 11:59:51 UTC
Created attachment 834308 [details]
Proposed fix for the guest agent fix

Comment 3 Eyal Edri 2014-02-10 09:49:37 UTC
moving to 3.3.2 since 3.3.1 was built and moved to QE.
if this is still targeted for z-stream, please clone bug to 3.3.2.

Comment 4 Jiri Belka 2014-02-12 12:09:17 UTC
Broken conflict comparison.

13:01 < vfeenstr> jbelka|lunch: I see, I messed that up the comparison -_-

Comment 6 Jiri Belka 2014-02-27 08:56:07 UTC
ok, rhevm-guest-agent-1.0.8-10.el5ev

Comment 9 errata-xmlrpc 2014-06-09 13:43:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0654.html


Note You need to log in before you can comment on or make changes to this bug.