Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1027381 - [RFE] Deprecate "basic fullscreen" mode
Summary: [RFE] Deprecate "basic fullscreen" mode
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Frantisek Kobzik
QA Contact: Artyom
URL:
Whiteboard: virt
: 1002690 (view as bug list)
Depends On:
Blocks: 1032960 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2013-11-06 17:09 UTC by Jonathon Jongsma
Modified: 2014-11-10 19:42 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-18 13:40:44 UTC
oVirt Team: ---
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)

Description Jonathon Jongsma 2013-11-06 17:09:51 UTC
virt-viewer currently has a --full-screen option that has an optional 'auto-conf' argument.  The main difference between the basic fullscreen mode and the auto-conf fullscreen mode is that basic fullscreen mode creates a window for each display that is currently configured on the guest and then makes these windows fullscreen.  If there are fewer guest displays than client monitors, the client monitors are left empty.  If there are *more* guest displays than client monitors, then all of the extra displays become windows hidden behind eachother on the last client monitor.

In contrast, when possible (i.e. with spice + vdagent) the auto-conf fullscreen mode tries to enable exactly the same number of guest displays as client monitors. This results in a much better user experience.  If auto-conf is unsupported, it behaves the same as basic fullscreen mode.

I propose to remove the distinction between these two modes and simply have a single mode that behaves as auto-conf currently does.

Comment 1 Marc-Andre Lureau 2013-11-06 19:30:17 UTC
I think that's the way to go, that's way the patch in virt-viewer is already on it's way upstream. Hopefully we don't have to carry a RHEV only patch.

Comment 2 Michal Skrivanek 2013-11-08 10:27:53 UTC
no objection from rhev side, we do need to clean up the mess in arguments being passed to spice in this specific area (ctrl-alt-del as well:)

Comment 3 Marc-Andre Lureau 2014-03-11 16:41:59 UTC
When is this RFE target? the earlier the better imho

Comment 7 Michal Skrivanek 2014-04-08 14:15:55 UTC
ok, let's do that...so what do we pass, what parameters and values exactly
- for .vv file
- for Firefox XPI / IE ActiveX plugin
Which version will support it? What about older clients behavior?

Comment 8 Jonathon Jongsma 2014-04-08 14:48:35 UTC
For new clients, fullscreen will imply auto-conf. So any explicit auto-conf arguments will simply be ignored. So we should try to make both new and old clients always do auto-conf when fullscreen is selected.  

In the case of the spi/activex plugins, you should probably set both FULL_SCREEN and AUTO_DISPLAY_RES to true.  The new client will simply ignore the AUTO_DISPLAY_RES flag, but will do auto-conf regardless.

For the vv-file, it's a bit more difficult to make old and new clients behave exactly the same because the vv-file format does not currently have a field for specifying auto-conf. There is only a single 'fullscreen' field that can be set.  If 'fullscreen' is set to 1, the new client would do auto-conf, but the old client would not. This issue is not specific to this change, however, since it also affects current RHEVM. See Bug 1083203 for discussion on addressing this issue.

Comment 9 Michal Skrivanek 2014-04-10 09:29:05 UTC
*** Bug 1002690 has been marked as a duplicate of this bug. ***

Comment 10 Michal Skrivanek 2014-04-10 09:34:25 UTC
ok, so it seems currently we need to:
1) on SPICE side to ignore the auto_res property. We are passing fullscreen to .vv and plugins accordingly.
2) in Basic User Portal correctly set default to "fullscreen" (doesn't work in 3.3)

Comment 11 Frantisek Kobzik 2014-05-12 13:56:56 UTC
Closing because since 3.4 fullscreen flag default is set correctly to true in basic user portal.

Comment 12 Frantisek Kobzik 2014-05-12 14:13:58 UTC
Hi Jonathon,

I'd like to handle this bug (I closed it already but I'm not sure if it's a good think). I'd like to ask you if Michal's 1st point in comment #10 is taken care of.

Thanks,
Franta.

Comment 13 Jonathon Jongsma 2014-05-12 21:03:13 UTC
I'm not entirely sure what Michal meant by "on SPICE side" in point #1.  If it means the spice client (e.g. remote-viewer), then it is being handled.

Comment 14 Michal Skrivanek 2014-06-25 07:43:16 UTC
(In reply to Jonathon Jongsma from comment #13)
can you please link the corresponding bug # for the spice-client just so we have a complete set of prerequisites to test this?

Comment 15 Michal Skrivanek 2014-07-18 10:17:54 UTC
(In reply to Frantisek Kobzik from comment #11)
doesn't seem to be set correctly in 3.4 GA

Comment 16 Frantisek Kobzik 2014-07-18 13:40:44 UTC
After further investigation it appears the fullscreen flag is set correctly:
 - true in _basic_ user portal
 - false otherwise.


Note You need to log in before you can comment on or make changes to this bug.