Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1027116 - [REPORTS-SETUP] - check installation dependencies before installation starts
Summary: [REPORTS-SETUP] - check installation dependencies before installation starts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On: 1058013
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-11-06 08:10 UTC by Barak Dagan
Modified: 2014-09-18 12:24 UTC (History)
10 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
rhevm-reports-setup now checks for missing dependencies before the installation begins, and fails early if those dependencies are not detected.
Clone Of:
Environment:
Last Closed: 2014-06-09 15:26:27 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0602 normal SHIPPED_LIVE rhevm-reports 3.4 bug fix and enhancement update 2014-06-09 19:26:10 UTC

Description Barak Dagan 2013-11-06 08:10:57 UTC
Description of problem:

Setup should check for missing dependencies such as files, DB, Users etc, before the installation starts and not when it is needed, in order to 
1) Save installation time (which is very long: 10-15 mins)
2) Re-install will not need to do cleaning tasks.

for example, missing file caught after >6 !!! minutes.


# rhevm-reports-setup 
Welcome to ovirt-engine-reports setup utility
In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Editing XML files...                                  [ DONE ]
Setting DB connectivity...                            [ DONE ]
Please choose a password for the reports admin user(s) (rhevm-admin and superuser): 
Warning: Weak Password.
Retype password: 
Warning: Weak Password.
Deploying Server...                                   [ DONE ]
Updating Redirect Servlet...                          [ ERROR ]
[Errno 2] No such file or directory: '/etc/ovirt-engine/engine.conf'

2013-11-05 20:36:09::DEBUG::rhevm-reports-setup::681::root:: /etc/pki/ovirt-engine/keys/engine.p12 exists, ovirt-engine is installed
...
2013-11-05 20:42:32::ERROR::rhevm-reports-setup::1213::root:: Exception caught!


Version-Release number of selected component (if applicable):
is21

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaniv Lavi 2013-11-06 08:13:06 UTC

*** This bug has been marked as a duplicate of bug 1026091 ***

Comment 2 Barak Dagan 2013-11-06 08:18:56 UTC
This is not duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1026091 since It's not about the missing file in engine-setup, but about checking phase in ovirt-reports-set

Comment 3 Itamar Heim 2013-11-06 11:03:42 UTC
1. if this bug is specific to a concrete bug in 3.3.0, please open a specific bug for 3.3.0 to fix it.
2. for the general bug title, i agree. we should add checks for things we may fail on (not all of them, i.e., don't try to do negative testing on this).
3. since we are re-writing the setup for 3.4, moving this generic one to 3.4.

Comment 8 Barak Dagan 2014-03-06 16:14:58 UTC
Verified on av2.1.

Seems to be working as part of the otopi framework, will be reopened if concrete issue is found.

Comment 9 errata-xmlrpc 2014-06-09 15:26:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0602.html


Note You need to log in before you can comment on or make changes to this bug.