Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 102447 - AP9212 firmware breaks apcmaster STONITH driver
Summary: AP9212 firmware breaks apcmaster STONITH driver
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: clumanager
Version: 2.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 87937
TreeView+ depends on / blocked
 
Reported: 2003-08-15 08:40 UTC by Steffen Mann
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version: 1.0.25-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-12-10 21:15:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:330 normal SHIPPED_LIVE New clumanager package fixes various bugs 2003-12-19 05:00:00 UTC

Description Steffen Mann 2003-08-15 08:40:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030708

Description of problem:
Clumanager software does log into APC Power Switch Model AP9212 via Telnet and
does send wrong info, instead of sending a 1 and a 1 to manage the Power Switch
it does send ESC and ESC.

Version-Release number of selected component (if applicable):
clumanager-1.0.19-2

How reproducible:
Always

Steps to Reproduce:
1.run clustermanager
2.Enjoy entrys in /var/log/messages
3.
    

Actual Results:  Doesnt manage the Switch

Expected Results:  Manage the Switch

Additional info:

Comment 1 Lon Hohberger 2003-08-15 12:28:53 UTC
(on vacation today, but)

The 'escapes' are sent to ensure that the switch is at the top menu.  It
actually sends five escape characters prior to attempting to manage the switch.  

I ran a 'clustonith -S'  and 'clustonith -l' on the test boxes and it logged in,
got a status report, etc (thus showing it got past the initial sending of escape
characters).  Can you attach the log messages?

The APC MasterSwitches, if I recall correctly, can support only one login at a
time, if that helps any.

Comment 2 Lon Hohberger 2003-08-18 21:55:34 UTC
Silly me.  APC MasterSwitch STONITH Module in Red Hat Cluster Manager 1.0.19 and
prior does not support use of the power switch by a non-administrative user.

I have an erratum which needs to be pushed out which addresses this and all the
other bugs open against 1.0.19.  There's a fix for this in the devel pool, but
it has not been tested internally (hardware -- lack thereof, actually).  The
patch was submitted by Marco Lusini, and the code looks clean and appears to fix
the problem.



*** This bug has been marked as a duplicate of 78667 ***

Comment 4 Lon Hohberger 2003-08-22 18:58:53 UTC
This was a bit more difficult than I originally guessed.

In the next erratum, a new STONITH driver will be provided which fixes this
problem as well as power-cycles all ports with the given name on the APC
MasterSwitch.

This driver has been tested on:
- APC MasterSwitch AP9212 revision 2.2.0
- APC MasterSwitch plus AP9225 revision 2.0.0

The apcplus driver works in both "Outlet User" and "Administrator" mode, and
should work when separate APC MasterSwitches are in use by the cluster software.

Still need to do a little more testing before releasing, but real progress ;)

Comment 5 Lon Hohberger 2003-08-25 15:09:14 UTC
Fix committed to pool; issue tracker updated.

New STONITH module: "apcplus".



Comment 6 Suzanne Hillman 2003-10-06 21:03:54 UTC
Already has errata-candidate, adding to U3 blocker bug list.


Note You need to log in before you can comment on or make changes to this bug.