Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1023330 - [RHEVM][webadmin] New Data Center "Guide Me" does not reflect hosts presence
Summary: [RHEVM][webadmin] New Data Center "Guide Me" does not reflect hosts presence
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.3.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Ravi Nori
QA Contact: Martin Pavlik
URL:
Whiteboard: infra
: 1057115 (view as bug list)
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2013-10-25 08:22 UTC by Martin Pavlik
Modified: 2016-02-10 19:20 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-24 21:31:03 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
screenshot 1 (deleted)
2013-10-25 08:22 UTC, Martin Pavlik
no flags Details
screenshot 2 (deleted)
2013-10-25 08:22 UTC, Martin Pavlik
no flags Details
screenshot 3 (deleted)
2013-10-25 08:23 UTC, Martin Pavlik
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23816 None None None Never
oVirt gerrit 24833 None None None Never
Red Hat Bugzilla 1057115 None None None Never

Internal Links: 1057115

Description Martin Pavlik 2013-10-25 08:22:28 UTC
Created attachment 816041 [details]
screenshot 1

Description of problem:

if user goes via

Data Centers -> New (fill in name, click OK) -> Configure Cluster (fill in: name, CPU name, click OK) -> Configure Host (fill in: Name, address, password, click OK) see screenshot 1

user ends up back in dialog which offers him to configure host under "There are still unconfigured entities:"

configure host button should move under optional actions (we already have a host and dialog statement "There are still unconfigured entities:" is not valid any more for the cluster)

moreover change mentioned above would make RHEVM behavior consistent with path
Clusters -> New -> Configure Host (see screenshot 2) (fill in: Name, address, password, click OK)
which puts "add another host" button under optional actions (see screenshot 3)

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.28.beta1.el6ev 

How reproducible:
100%

Steps to Reproduce:
see description

Actual results:
button for adding hosts does not move under optional actions after adding host to cluster in New Data Center guide me dialog

Expected results:
button for adding hosts moved under optional actions after adding host to cluster in New Data Center guide me dialog


Additional info:

Comment 1 Martin Pavlik 2013-10-25 08:22:49 UTC
Created attachment 816042 [details]
screenshot 2

Comment 2 Martin Pavlik 2013-10-25 08:23:29 UTC
Created attachment 816043 [details]
screenshot 3

Comment 3 Barak 2013-10-27 12:36:08 UTC
I don't think this is a bug,
Arthur ?

Comment 4 Arthur Berezin 2014-01-24 00:17:08 UTC
Is bug is in the flow if "Guide me". Should this be under UX ?

Comment 5 Einav Cohen 2014-01-24 21:31:03 UTC
(In reply to Arthur Berezin from comment #4)
> Is bug is in the flow if "Guide me". Should this be under UX ?

this bug is in the flow of the Data-Center "Guide Me" which is under the 'infra' team domain of responsibility. 

in any case - this is a duplicate of bug 1057115, please see bug 1057115 comment #2 for the needed changes.

*** This bug has been marked as a duplicate of bug 1057115 ***

Comment 6 Einav Cohen 2014-01-24 21:32:03 UTC
closed on duplicate of an ovirt BZ by mistake, not sure that I should do that - re-opening. 
adding to the See Also section instead.

Comment 7 Ravi Nori 2014-02-20 21:45:36 UTC
*** Bug 1057115 has been marked as a duplicate of this bug. ***

Comment 8 Martin Pavlik 2014-03-11 07:52:40 UTC
works in av 2.1

button for adding hosts moved under optional actions after adding host to cluster in New Data Center guide me dialog

Comment 9 Itamar Heim 2014-06-12 14:07:07 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.